512G not powering up for more than 2 seconds

Simcor

Active Member
Joined
Oct 24, 2017
Messages
126
Likes
52
Country
United Kingdom
#1
The old 512G that I put in my parent's car has stopped working.

It turns on for a few seconds then powers off, even using a charge plug and cable in the house it just turns on then off constantly.

I am thinking the battery is goosed as I have opened it up and the battery pack is swollen quite a lot. Very rounded and bulged.

I was thinking of ordering a replacement battery to try this but wanted to make sure it's not likely to be anything else.
 
OP
OP
S

Simcor

Active Member
Joined
Oct 24, 2017
Messages
126
Likes
52
Country
United Kingdom
#2
That's how swollen the battery is.

I have unsoldered the battery thinking if it was battery related then maybe it would power up as normal on power without the battery connected.
I know that's a long shot as the circuit is probably expecting a battery to be there.

But it still goes in and on off loop.

Don't really want to order a battery if the camera is goosed.
 
OP
OP
S

Simcor

Active Member
Joined
Oct 24, 2017
Messages
126
Likes
52
Country
United Kingdom
#3
Found a better usb cable and it powers up ok and stays on.
Seeing if the battery will hold a charge at all but it needs replacing anyway.
 

kamkar1

Well-Known Member
Joined
Oct 11, 2013
Messages
19,138
Likes
10,091
Country
Denmark
Dash Cam
Lukas LK-7500G / Innovv C3 / mobius / G1W / SG9665GC & more
#5
Yes dispose of that battery in a safe manner.

You might want to take its outside measurements and maybe keep pice of the wire with the plug on in case you cant source a battery wit the correct plug on it.
But otherwise these little 1 cell lipo batteries can be found many places
 
OP
OP
S

Simcor

Active Member
Joined
Oct 24, 2017
Messages
126
Likes
52
Country
United Kingdom
#6
It's gone back to not even powering up again now. I think it's had it tbh. It has corrupted the sd card too guess from not being able to save clips properly.
 
OP
OP
S

Simcor

Active Member
Joined
Oct 24, 2017
Messages
126
Likes
52
Country
United Kingdom
#7
Removed the battery again and it still won't power up, just get a rapid flashing blue light and nothing. So I think its dead.
 
OP
OP
S

Simcor

Active Member
Joined
Oct 24, 2017
Messages
126
Likes
52
Country
United Kingdom
#8
Nope, we are back to a working dash cam after putting the sd card back in with the firmware update on it, It must have gone wrong when I tried updating the firmware.
 
OP
OP
S

Simcor

Active Member
Joined
Oct 24, 2017
Messages
126
Likes
52
Country
United Kingdom
#9
Battery replaced thanks to Tiff for getting me one out so quickly.

Also they have sent me a 412GW battery as its a bit larger and should last a bit longer than the original did on battery usage.

All working and seems to be fine now.
 
Joined
Dec 27, 2017
Messages
73
Likes
13
Country
United Kingdom
Dash Cam
512GWR, 512G.
#10
After upgrading from the 512G Im planning to try the old camera in my wifes car.
Interesting that your battery had overheated, do you think it was a fault or just old age?
Ive had some Chinese batteries melt and overheat in other situations but never had one catch fire, just wondering about the risks involved with the camera so close to the roof lining?
 
OP
OP
S

Simcor

Active Member
Joined
Oct 24, 2017
Messages
126
Likes
52
Country
United Kingdom
#11
I had a 412G that the battery bulged that much the casing was bulging as well, I think its more to do with constant charging and discharging and also heat from the sun what little we normally get.

The 512G had been fine all the time I had it in my car, I bought the newer 512GW and put my old 512G in my parent's car and it was still working OK initially.

It was probably 2 or 3 years old off the top of my head as I can't remember when I took the 412G back and got the 512G as a replacement.
 
Thread starter Similar threads Forum Replies Date
M Nextbase 15
S Nextbase 1
B Nextbase 65

Similar threads

Top