BlackVue DR500GW HD with T-Power C

maxblast

New Member
Joined
Jan 11, 2014
Messages
8
Reaction score
0
I have my blackvue for months and initially installed it with a Power Magic Pro. The Power Magic did not work properly in my BMW so I bought a T-Power C as alternative.
For some reason the DC power plug of the T-Power C cable is not making a good connection with my Blackvue. I often have to tap the plug a bit to revive my Blackvue but more and more there is no power.
I bought the T-Power C from an Ebay seller and the anypower.com website is Korean and does not show any support e-mail.
Just wondering if there is anyone else with the same issue. Perhaps it is solved when I use a DC 2,5 mm extension cable?
Thanks in advance.
 

Hillbilly

Well-Known Member
Joined
Feb 14, 2013
Messages
1,744
Reaction score
251
Location
Sunshine Coast
Country
Australia
Dash Cam
DR750s x2 DR450 x2
The power magic would have worked if it was wired up correctly.

Get the correct plug for the camera and splice it onto the cable from the Tpower.
 
OP
M

maxblast

New Member
Joined
Jan 11, 2014
Messages
8
Reaction score
0
I hardwired the Power magic but the battery drainage caused the Power Magic to switch off all the time so how would you have wired up the Power Magic in a E90 BMW?
 

Hillbilly

Well-Known Member
Joined
Feb 14, 2013
Messages
1,744
Reaction score
251
Location
Sunshine Coast
Country
Australia
Dash Cam
DR750s x2 DR450 x2
If you were having trouble I would have wired it directly off the battery through a 2 amp line fuse to the PM.

How old is the Beemer

If the PM was cutting out the battery may be on its last legs.
It wouldn't run a battery down to the cutoff level of a good battery in parking mode in less than about 16 hours I would think .

Yellow direct to battery red to an ignition switched circuit Black to earth Too easy.

Parking mode on say 6 hours. Cutoff 12 volt
 
OP
M

maxblast

New Member
Joined
Jan 11, 2014
Messages
8
Reaction score
0
I had the PM connected directly to the battery. It is a 2012 BMW. I was told that my type of BMW was sensitive to battery drainage and that is why I decided to get the T-Power C battery solution. Not sure about the parking mode setting but the cut off was set to 11,8 volt.
 

tonymy01

Member
Joined
Jul 9, 2013
Messages
58
Reaction score
0
Location
Sydney
Country
Australia
Mine switches off most times when unlocking the car, as I have the leaving home lights on in my Golf and it must drop the power briefly below 11.8V,and the power magic pro seems to cut off the moment there is a dip. I originally had it set to a higher cut off voltage but it was worse of course.
 
OP
M

maxblast

New Member
Joined
Jan 11, 2014
Messages
8
Reaction score
0
This could be my problem as well. My welcome lights are also on when I unlock and when I start the engine, the blackvue is already powering down. Perhaps a stronger battery would do the trick.
 
Last edited:

hari

New Member
Joined
May 14, 2014
Messages
2
Reaction score
0
Country
Australia
just splice it, the connectors that come with T-POwer C arent great quality either. I bought myself better quality cigarrette socket connecters , spliced the wires too
 

Similar threads


Top