Camera WiFi in Client mode - WORKING .ash SCRIPT inside

Discussion in 'Yi Action Camera' started by Andy_S, Jun 21, 2015.

  1. Evils

    Evils New Member

    Messages:
    4
    Likes Received:
    0
    Country:
    Germany
    Got it working, the issue was that the option for "Start Wifi on boot" was on and was interfering with the script
     
  2. sYCO

    sYCO New Member

    Messages:
    14
    Likes Received:
    1
    Country:
    Germany
    Sorry, but what exactly is this script for?
     
  3. Manoj George

    Manoj George New Member

    Messages:
    7
    Likes Received:
    0
    Country:
    United States
    Hi I cannot connect to my wi-fi. Things that I tried:
    1. Set Router to accept WPA and WPA2
    2. Tried firmware 1.2.13 and 1.2.0
    3. Tried with and without watchdog, with and without static ip and with and without custom mac

    The files I am using are attached. Can I get some help? Sorry new to the camera.
     

    Attached Files:

  4. Manoj George

    Manoj George New Member

    Messages:
    7
    Likes Received:
    0
    Country:
    United States
    Also when I turn the camera on, the blue wi-fi light comes on and stays on. I get a short beep followed by a longer beep. And the blue wi-fi light starts to blink.
     
  5. Israel

    Israel New Member

    Messages:
    1
    Likes Received:
    0
    Country:
    Peru
    Not working on my yi :( i have 1.2.13 and have set everything.
    questions:
    1- On static ip mode where do i set the router ip?
    2- In sta.sh there seem to be a duplicated line, is this correct? the lines are identical :
    killall -9 hostapd hostapd_autochannel_retartchip dnsmasq udhcpc wpa_supplicant wpa_cli wpa_event.sh 2> /dev/null
    killall -9 hostapd hostapd_autochannel_retartchip dnsmasq udhcpc wpa_supplicant wpa_cli wpa_event.sh 2> /dev/null
    3- any pill for frustration?
     
  6. vadimkozhin

    vadimkozhin New Member

    Messages:
    19
    Likes Received:
    3
    Country:
    Latvia
    Israel, you should put router IP in watchdog.sh, if you use watchdog. I have also duplicate line in sha.sh, and it works fine.

    Did you put "sleep 10" in autoexec.ash before you triggering "lu_util exec '/tmp/fuse_d/wifi/sta.sh'"? WiFi on cam need some time to 'power up' before start connection to router.

    And also you need to comment last line "udhcpc -i wlan0 -A 2 -b -t 30" in sta.sh if you want to use static IP's on cams.
     
  7. tted01245

    tted01245 New Member

    Messages:
    2
    Likes Received:
    0
    Country:
    China
    I could't connected my router,i tryed everyting i can there was a beep after start,but noting happened.
    the camera still start its own wifi router
     
  8. Kylehufford

    Kylehufford New Member

    Messages:
    3
    Likes Received:
    0
    Country:
    United States
    At the risk of ridicule for being a newbie I will go ahead and post our issues. I am trying to setup 6 YI 4K action cams. I am trying to use with script to connect to a Verizon Jetpack MiFI. I have the password and network name correct. However, I never get a camera to connect. No beep after 30sec. Not sure where we went wrong. Maybe this will not work with a MIFI. Any help would be appreciated.
     
  9. Manoj George

    Manoj George New Member

    Messages:
    7
    Likes Received:
    0
    Country:
    United States
    It should work. The one thing I had to do make sure that wifi is not setup to start automatically (this is an option for the camera). Once the setting was off, I was able to connect to an existing wifi.
     
  10. Kylehufford

    Kylehufford New Member

    Messages:
    3
    Likes Received:
    0
    Country:
    United States
    Do you mean just make sure the WIFI is off before turning the camera off before trying the script?
     
  11. Kylehufford

    Kylehufford New Member

    Messages:
    3
    Likes Received:
    0
    Country:
    United States
    I also just tried using my iPhone's hotspot to check and that did not work either. Both with the WIFI set to turn on at startup and with it off. Could it be the 4K action cam does not handle scripts in the same way?
     
  12. tted01245

    tted01245 New Member

    Messages:
    2
    Likes Received:
    0
    Country:
    China
    XiaoYi 4k has its own Api and client mode firmware:https://github.com/YITechnology/YIOpenAPI
     
  13. JRSim_UIX

    JRSim_UIX Member

    Messages:
    83
    Likes Received:
    16
    Country:
    United Kingdom
    Wait what. You bought 6 4K Yis!!!
    Wowzaa.. Jealous ;)
     
  14. sunnyPYBURN

    sunnyPYBURN New Member

    Messages:
    10
    Likes Received:
    0
    Country:
    United Kingdom
    Hi guys, help needed getting my phone to recognise my Xaiomi Yi cameras. I have dloaded the scripts, edited the wpa_supplicant.conf with my hotspots name and password, as for the sta.sh file I only added a # at the beginning of line 51 to create ip addresses. Still nothing.

    Rather type out everything I have created a video to make it easier to find out whats going on -

    If anyone can shed some light that would be great! :)
     
  15. vadimkozhin

    vadimkozhin New Member

    Messages:
    19
    Likes Received:
    3
    Country:
    Latvia
    sunnyPYBURN, you need to _uncomment_ (remove # symbol) from one of those lines, depends on what mode you want. Here is the screenshot from your video: http://take.ms/V7Kzp

    Uncoment line 1 if you want to get static IP's on your cams (but be sure to get right subnet and IP) or uncomment line 2 to get DHCP, or dynamic IP (the router will give them free addrerss automatically).

    So, you need to remove last # symbol before last line. And last line of this file should be empty.
     
  16. sunnyPYBURN

    sunnyPYBURN New Member

    Messages:
    10
    Likes Received:
    0
    Country:
    United Kingdom
    Hi vadimkozhin thanks for this,

    I'll be honest I don't know which mode I want. What are the differences between the modes? What I think I understand is that static ip is an ip address hardwired somewhere inside the yi (maybe firmware?) and dynamic ip means the router (my phone in hotspot mode) will create and assign an ip address to each Yi. I will only ever use these cameras in a configuration whereby the phone is the router. Does this make a difference?
     
  17. vadimkozhin

    vadimkozhin New Member

    Messages:
    19
    Likes Received:
    3
    Country:
    Latvia
    sunnyPYBURN, my suggestion is use the dynamic (DHCP) mode. It should work fine in your case.

    The difference in your case will be — if you use static addresses, you need to configure router (or phone in your case), to use proper IP address range. Somewhere in the setting on your phone app should be something like 'IP address range' or similar, and something like 192.168.1.100-200 (numbers can be different). It means that router will allow all clients (devices which connects to it) addresses in range from 192.168.1.100 till 192.168.1.200, so you'll need to configure each camera config accordingly — which means give addresses to cams in 'correct' router range. Dynamic IP's means the router will automatically give the IP's to cameras, so you'll don't need to worry to give them proper addresses. That's simple explanation.

    So, it depends from how you will be using it. For example Brahma app can scan for range of IP's to find all cameras, so it can be dynamically assigned, but Andy_S python app – don't, so you'll need to know exact IP to connect to cam. In some cases one preferable over another.

    In your case your you should use dynamic configuration.

    p.s.
    If you still don't get a success, show us the scripts, I mean, upload the ZIP with your configuration.
     
  18. JRSim_UIX

    JRSim_UIX Member

    Messages:
    83
    Likes Received:
    16
    Country:
    United Kingdom
    Agree with vadimkozhin - comment line 51 with hashtag uncomment line52 remove hashtag.
    Also - I'm not sure what tool you are editing the scripts with on a mac but there have been mac users having issues with the scripts as mac save the text format in some funny encoding where it adds characters that you can't see and breaks the scripts.

    If you can use windows and notepad++ or search the forum for mac users there is a texteditor that will work that doesnt add invisible characters that break the scripts but I can't remember what it is.
     
  19. sunnyPYBURN

    sunnyPYBURN New Member

    Messages:
    10
    Likes Received:
    0
    Country:
    United Kingdom
    Guys just to be ultra clear, to "uncomment' something is to just delete the # symbol at the beginning of a line and to "comment" is to type in a # symbol at the beginning of line of code?

    Is this like muting and unmuting that particular code/instruction?
     
  20. vadimkozhin

    vadimkozhin New Member

    Messages:
    19
    Likes Received:
    3
    Country:
    Latvia
Loading...

Share This Page