Cannot update my firmware from 3.7 to 4.0

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
When i plug in my dashcam 55 and then click install updates in Express, it seem to finish and work. Then once I disconnect my camera and then go to settings>about, it says its still at 3.7. I pug my camera back into my computer and it keeps saying install updates.

So for some reason the updates are not sticking. Does anyone know why?
 

DC55User

New Member
Joined
Jun 22, 2018
Messages
23
Reaction score
8
Country
United States
The camera must be plugged back in to power it up and finish the installation. Plugging into the computer will not accomplish this. It must be powered on with the power cable.
 
OP
truetaurus

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
I think I tried this. I basically installed the update, then I unplugged the camera and went to my car and plugged it in using the power from the cigarette lighter but still nothing. Whats the exact process then? leave it plugged in for a while?

This is exactly what I did:
Plugged into computer
installed updates
safely removed the usb device
unplugged from computer
plugged into cigarette lighter in car
it came on to setup
went through the setup like selecting language etc
went to settings>about and found it STILL is 3.70
 
Last edited:

DC55User

New Member
Joined
Jun 22, 2018
Messages
23
Reaction score
8
Country
United States
When I plugged mine in to the car cable, it kind of hung up on the software install. I had to shut the camera completely off and then restart it. Then the software finished installing and has been running fine since. I can't say it went smoothly for me. Maybe it will take a couple restarts for you as well.
 
OP
truetaurus

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
WHen you plugged it into the car what happened? Mine just switches on and shows the setup steps. Should in show some sort of "Completing installation" screen?
 

DC55User

New Member
Joined
Jun 22, 2018
Messages
23
Reaction score
8
Country
United States
When I first plugged it into the car, the camera came on but essentially did nothing else. I had to hold the power button for 5 seconds to power the camera off. Then I pressed the power button once to turn it back on and only then did the software finish installing and then the camera booted up normally. I hope this helps and you get it up and running!
 
OP
truetaurus

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
oh man unfortunately I have done all that now and still does not stick the new updates. maybe I have to send them back.
 

MartK

New Member
Joined
Dec 27, 2018
Messages
22
Reaction score
2
Country
Australia
Did you get this resolved ever? Got the same issue here
 

MartK

New Member
Joined
Dec 27, 2018
Messages
22
Reaction score
2
Country
Australia
Ok just an update as to what I did. Start from scratch... Do a factory reset on the device. Plug it into the PC or MAC and do the update and wait for it to say the update is successful. Then when you turn the device on it says something like to plug it into an external power source (ie not the PC or Mac) so then just go to your car, plug it into the car cigarette lighter and let itauto start up and then it should continue the device side of the update. Its almost like starting it on windows is just copying the update files over onto the device maybe? Then after that, having it plugged into the car finishes the job off.

Hope that helps.
 
OP
truetaurus

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
Hey yes i think i resolved this, i had 2 cameras, the second one as you said worked but the first one seems like its broken. I have a feeling because i plugged in the wrong power once.
 

MartK

New Member
Joined
Dec 27, 2018
Messages
22
Reaction score
2
Country
Australia
Oh no. Thats exactly what I did too actually I plugged it into 3 different power sources and was worried it may have damaged the device. what exactly is wrong with the first one? Will it turn on? At all?
 
OP
truetaurus

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
it turns on and everything but the update never sticks. When i plug it into a power source it just turns on normally without finishing updating. I also noticed after a while it got quite hot when in use but not sure if thats normal or not.
 

MartK

New Member
Joined
Dec 27, 2018
Messages
22
Reaction score
2
Country
Australia
I had a read of their FAQ and yes it seems that is normal particularly when recording in 1080. I would have that if the incorrect power did damage the device it would not turn on at all. With the device which is not working have you tried a factory reset and then the update?
 
OP
truetaurus

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
where is factory reset? settings>system>setup>restore?
 
OP
truetaurus

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
Yeah this still didnt work unfortunately. What I did notice is when i plug in the camera that works windows find removeable drive F only, but the "broken" camera finds removable drive e and f
 

MartK

New Member
Joined
Dec 27, 2018
Messages
22
Reaction score
2
Country
Australia
Have you tried plugging it into another USB port?
 

MartK

New Member
Joined
Dec 27, 2018
Messages
22
Reaction score
2
Country
Australia
Try plugging it into another USB port and also does Garmin Express see the device ok?
 
OP
truetaurus

truetaurus

New Member
Joined
Dec 20, 2018
Messages
10
Reaction score
0
Country
Germany
yeah still 2 drives. Weird part is the drive F is 42 mb in size and the drive e is the 8gb with the Garmin files. On the fixed cam, there is only drive f and thats 8gb and has the garmin files.

Garmin express sees the device and even installs the updates but they dont stick still
 
Thread starter Similar threads Forum Replies Date
M Dash Cam 55 1
R Dash Cam 55 2
M Dash Cam 55 5

Similar threads


Top