Coaxial

Cashy

New Member
Joined
Nov 21, 2013
Messages
4
Likes
1
Country
United Kingdom
#1
Hi, having a problem with my channel 2 camera or coaxial, my rear camera is not powering up, and when coaxial connected front camera not powering either, but when i unplug coaxial, front camera comes on, does this sound like i need a new coaxial lead to you? the plugs and sockets seem undamaged so not sure.
 

Module 79L

Well-Known Member
Joined
May 17, 2015
Messages
3,765
Likes
1,486
Country
Portugal
Dash Cam
AT11DA, SG9665XS, G1W-H
#3
Hi, having a problem with my channel 2 camera or coaxial, my rear camera is not powering up, and when coaxial connected front camera not powering either, but when i unplug coaxial, front camera comes on, does this sound like i need a new coaxial lead to you? the plugs and sockets seem undamaged so not sure.
If the rear camera is powered by the front camera then the cable has a short-circuit in the power wires.
 

JohnM

Active Member
Joined
Dec 6, 2015
Messages
197
Likes
31
Location
Lincs
Country
United Kingdom
Dash Cam
DR650GW-2CH
#4
Hi Cashy

You'll need a magnifying glass to properly check your coax pins and plugs. New cables are available for about £15. If the plug is damaged, it will need to go back for repair.
 
OP
OP
C

Cashy

New Member
Joined
Nov 21, 2013
Messages
4
Likes
1
Country
United Kingdom
#5
Thanks for the reply's guys, new coax ordered, will update.
 
OP
OP
C

Cashy

New Member
Joined
Nov 21, 2013
Messages
4
Likes
1
Country
United Kingdom
#6
New cable came today, all working fine again. Thanks for the suport.
 
Top