"DashCam Viewer" is NOT reading or displaying GPS info

Ant

New Member
Joined
Oct 1, 2016
Messages
25
Reaction score
12
Country
United States
I am using the "DashCam Viewer" software and only the video gets played.
https://dashcamviewer.com/

BUT none of the GPS info is being read by the software.

===================

Here is a YouTube video of the A119 ( w/GPS) being successfully used and demonstrated with the "DashCam Viewer" software.

https://youtu.be/amjcsoExAQU? t=11m3s

===================

So I went to the FAQ section of the "DashCam Viewer" website and scrolled down to question #18 " I don’t see any GPS data. Why? "

https://dashcamviewer.com/faq/


" Without more specific info it is difficult to diagnose the problem. Here are a few things to check:

3) - Make sure your internal clock is set to the correct timezone and correct time. DCV relies on the correct timestamp of the movies to sync with the GPS data files. The GPS, your computer, and the dashcam should all have the correct time.

4) - If that doesn’t work, send me a clone of your SD card that contains about 3 movies on it and I will try to diagnose the problem. It’s important that you send me an image of the SD card such that the file and folder structure is preserved. The structure should look something like that below. You can send me a zip of the SD card via https://wetransfer.com using my email address as the destination. "
 

viofo

Well-Known Member
Manufacturer
Joined
Sep 29, 2015
Messages
1,147
Reaction score
2,384
Location
Shenzhen
Country
China
Dash Cam
A129 Pro / A129 Duo / A119 V3 / A119S / G1W-S / WR1/
First make sure you have enabled the GPS, and turn on the GPS data stamp.
After enabled, you can see the speed showed on camera LCD screen, and GPS info on video.
This make sure the camera logged the GPS.
 
OP
A

Ant

New Member
Joined
Oct 1, 2016
Messages
25
Reaction score
12
Country
United States
Thanks for the reply.

The GPS info shows up fine on the recorded video.

=============

The issue here is that I am using the "DashCam Viewer" software and only the video gets played.
https://dashcamviewer.com/

BUT none of the GPS info is being read by the software.

NONE of the GPS info is being displayed in the "Google Maps" or "Graph" windows of the software.

===================

Here is a YouTube video of the A119 ( w/GPS) being successfully used and demonstrated with the "DashCam Viewer" software.

https://youtu.be/amjcsoExAQU? t=11m3s
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
52,118
Reaction score
29,978
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
best to ask @traveler for advice on Dashcam Viewer

make sure your camera is on latest firmware and you have the latest version of Dashcam Viewer also
 
OP
A

Ant

New Member
Joined
Oct 1, 2016
Messages
25
Reaction score
12
Country
United States
Thanks for the reply.

Who is @traveler ?

What is their email address ?

Do they have a website where I can get ahold of them ?
 

traveler

Well-Known Member
App Developer
Joined
Jan 17, 2014
Messages
438
Reaction score
836
Location
Orange County, CA
Country
United States
Dash Cam
Viofo A119V2, SG9665GC, SG9663DCPro + many more
OP
A

Ant

New Member
Joined
Oct 1, 2016
Messages
25
Reaction score
12
Country
United States
RESOLVED

I went to http://www.viofo.com/home/30-a119-1080p-60fps-dash-cam.html a

Clicked on the " Support Tab "

1. Clicked on the "Download" link for the latest firmware ( A119.20160829.V1.1 ) from August 28, 2016.

2. Unzip the file using available unzip programs, e.g. WinZip or 7-Zip

3. Open the file and copy the .bin file directly onto the MicroSD card root file(use a 32GB maximum card, FAT32 format.)

4. Insert the MicroSD card into the cam and power it on via a 5V/1A power source, e.g. cigarette lighter or power bank, it will start upgrade automatically.

5. While upgrading the front REC red LED starts blinking(the light blinking slowly at the beginning, then blinking quickly), after the light stop blinking, it means upgrade is finished, the firmware will be deleted automatically after upgrade.

6. You will need to RE-configure your dashcam settings since they will be lost during the upgrade



====================

The next part is to download and install DashCam viewer from https://dashcamviewer.com/

I installed :

Current Version: v2.2.0
Release Date: September 4, 2016

You can read the Version Changelog by going to https://dashcamviewer.com/blog/ or https://dl.dropboxusercontent.com/u/25150850/history.pdf

You can also download the User Manual at https://dl.dropboxusercontent.com/u/25150850/Dashcam Viewer Users Manual.pdf

You can see a Video Tutorial at


============

FYI -


Windows Requirements:

Windows 10 is recommended but Dashcam Viewer might still run on earlier OS’s (Windows 7 and 8). 32-bit and 64-bit versions are available.

Low-end Windows PCs with poor video performance and limited screen resolution are not recommended.

FYI -


Also there are times where IF your device did not start logging the GPS early into the movie, it might not display in the Dashcam Viewer software.

This might also happen if you are playing multiple movies sequentially.

FYI -


Interestingly, even though my A119 had the current firmware installed from the factory , I had to download and install the exact same version to get it to work with the DashCam viewer software.


=============

If you want to UN-install the Dashcam Viewer software...


Windows:


    • Right-click on the Dashcam Viewer icon on the Desktop
    • Select "Open file location" from the menu.
    • In the Dashcam Viewer folder, select and run "unins000.exe"
    • Dashcam Viewer will be removed from your system.

Mac OS X:

    • Open your Applications folder.
    • Select the Dashcam Viewer application and drag it to the trash
    • Dashcam Viewer is now removed from your system
================

Let me know if this helped.


Feel free to "like" this post.

 
Last edited:

estore009

Well-Known Member
Retailer
Joined
Nov 25, 2013
Messages
2,660
Reaction score
1,316
Location
Shenzhen
Country
China
Dash Cam
B1W/B2W/B2K/B4K/DV688/DV988/B1M/B2M
thanks for your updated info.
 
OP
A

Ant

New Member
Joined
Oct 1, 2016
Messages
25
Reaction score
12
Country
United States
No problem.

Please "like" the post.
 

RogerL

New Member
Joined
Nov 6, 2016
Messages
9
Reaction score
2
Country
United Kingdom
I am running firmware A119.160829.V1.1 and this doesn't resolve the issue for me (and I did try a re-install of this as suggested above)

Looking at the video file with a hex editor I can see exactly the sort of corruption that @traveller mentioned with the datestamp - the time, year and month are correct, but not the day.
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
52,118
Reaction score
29,978
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
I am running firmware A119.160829.V1.1 and this doesn't resolve the issue for me (and I did try a re-install of this as suggested above)

Looking at the video file with a hex editor I can see exactly the sort of corruption that @traveller mentioned with the datestamp - the time, year and month are correct, but not the day.


if you have a sample file and the details of the corruption and can send them to @viofo they will be able to get the engineer to check it, if there's an error there they will be able to get it sorted
 

HardNougat

New Member
Joined
Nov 4, 2016
Messages
14
Reaction score
3
Country
United States
Dash Cam
Viofo A119
I started having this issue once I updated my FW to v2.0...thinking it might work if I switch back to v1.1 because both the cam and software worked fine out of the box.
 

RogerL

New Member
Joined
Nov 6, 2016
Messages
9
Reaction score
2
Country
United Kingdom
I am still having the issue with 1.1, but it's probably worth a try as this seems to fix it for some people.

I have been experimenting a bit changing video and date formats in case that made a difference, but I always see the same corruption.

For info, my preferred format is 2560x1440p 30fps with date format dd/mm/yy but I have also tried 1920x1080 at both speeds and date format yy/mm/dd but the day written to the MP4 file is always corrupt.
Dashcam viewer just shows the position at the end of each mp4 file, no intermediate positions and no speed/heading info
 

traveler

Well-Known Member
App Developer
Joined
Jan 17, 2014
Messages
438
Reaction score
836
Location
Orange County, CA
Country
United States
Dash Cam
Viofo A119V2, SG9665GC, SG9663DCPro + many more
I started having this issue once I updated my FW to v2.0...thinking it might work if I switch back to v1.1 because both the cam and software worked fine out of the box.

Thanks to an A119 user who provided me with a FW 2.0 sample movie, I found that FW 2.0 stores the GPS data at a different byte offset within the movie file as compared to FW1.1. This would make Dashcam Viewer v2.2.2 fail to find the GPS data. I've made adjustments to the development version of DV to accommodate both FW1.1 and FW2.0. This will be posted in the next s/w release. Hopefully there won't be another format change by then. ;-)

John

Website: http://dashcamviewer.com
Facebook: https://www.facebook.com/dashcamviewer
 
Last edited:

HardNougat

New Member
Joined
Nov 4, 2016
Messages
14
Reaction score
3
Country
United States
Dash Cam
Viofo A119
Thanks to an A119 user who provided me with a FW 2.0 sample movie, I found that FW 2.0 stores the GPS data at a different byte offset within the movie file as compared to FW1.1. This would make Dashcam Viewer v2.2.2 fail to find the GPS data. I've been adjustments to the development version of DV to accommodate both FW1.1 and FW2.0. This will be posted in the next s/w release. Hopefully there won't be another format change by then. ;-)

John

Website: http://dashcamviewer.com
Facebook: https://www.facebook.com/dashcamviewer

I'm glad to hear straight from the dev that it's just a fw issue! Any ETA on when the next version should be released?
 

F0x135

New Member
Joined
Oct 8, 2016
Messages
28
Reaction score
6
Country
Australia
OK @HardNougat, the new version is released. Check out this thread. Hope it works for you.

Unfortunately just like your older version, i still can't get this to work :/

All i get is a black screen - play / pause does nothing whilst the movie shows up in 'movies & geotags'.
 
Top