DR 550GW-2 CH Rear camera not working

Discussion in 'DR550GW-2CH' started by ucsmfu, Feb 8, 2015.

  1. ucsmfu

    ucsmfu New Member

    Messages:
    12
    Likes Received:
    0
    Country:
    Canada
    Properly wired everything up on a 2013 Mercedes GLK with power magic pro, everything powered up properly. Then after 3 min the rear camera stopped working. I testing everything out, made sure the wires for power magic in the fuses were secure, properly grounded. I even took out the Power magic pro and just plugged it in the cigarette lighter and still no luck. Lastly, my buddy had a brand new DR 5550, so I swapped the rearview cams around, didn't work, tried his cables etc... didn't work either.

    Could the rearview camera be defective ?

    Thanks
     
  2. michael007

    michael007 Member

    Messages:
    38
    Likes Received:
    13
    Country:
    Canada
    Well if you swapped your friends rearview camera and it still doesn't work, then it sounds like your main camera that receives the feed is either defective or the firmware has a problem.

    Check if you're running the latest firmware and if so, contact the provider you purchased it from. Hope you can work it out!
     
  3. dyel74

    dyel74 Member

    Messages:
    64
    Likes Received:
    15
    Country:
    Australia
    Dash Cam:
    Blackvue DR600GW, DR3500FHD, Street Guardian SG9665GC
    Also check if you have inadvertently bent the tiny pin in the coaxial cable that connects your rear view camera to the front camera. This is often the main cause of the rear camera not working, especially if you have tried another brand new 550 rear (which again points to a cable issue).
     
  4. Zroiron

    Zroiron New Member

    Messages:
    3
    Likes Received:
    0
    Country:
    United States
    My rear camera stopped working also. I noticed that the light that normally pulses was constantly on. I unplugged it then reconnected it and now the light does not come on at all. I'm thinking about ordering a new rear camera, since I've already replaced the main camera just over a year ago.
     
  5. alexsoll

    alexsoll Well-Known Member Retailer

    Messages:
    1,596
    Likes Received:
    1,145
    Location:
    Minsk
    Country:
    Belarus
    Dash Cam:
    Street Guardian, BlackVue, TrendVision www.autodvr.by
    95% of the problem is not the rear camera. There is nothing to break.
     
  6. jermyzy

    jermyzy New Member

    Messages:
    19
    Likes Received:
    0
    Country:
    Canada
    Bah, I'm having same problem. Light was flickering yesterday, today the light is completely off and rear camera is dead. I unplugged cables and replugged but still dead. I can't tell if the cable is broken or the camera...
     
  7. Zroiron

    Zroiron New Member

    Messages:
    3
    Likes Received:
    0
    Country:
    United States
    My main camera was the culprit. I purchased an identical 550, installed the new rear camera...same problem. Installed the new front camera....bingo!..reinstalled the old rear camera...bingo! It works! Now I will try the firmware update suggestion. If it solves problem I'll sell the old camera. If not I will be stuck with two cams!
     
  8. jermyzy

    jermyzy New Member

    Messages:
    19
    Likes Received:
    0
    Country:
    Canada
    Thanks for the update...this is very frustrating. I installed newest firmware last night, and rear camera started working! Problem Solved...I thought...this morning on the way to work, rear camera turned on, but halfway on drive to work, rear camera failed again...
     
  9. Kacper

    Kacper New Member

    Messages:
    1
    Likes Received:
    0
    Country:
    United States
    I am new to dash cameras and i recently got my blackvue 550 2 channel dash cam and I wired up everything with magic box pro and whenever I plug in the rear camera magic box fails and doesn't want to turn on for a while. What could be the cause ?
     
Loading...

Share This Page