DR650GW-2CH Firmware Help?

JKWelsh

New Member
Joined
Oct 6, 2013
Messages
15
Reaction score
1
Country
United Kingdom
Hi Guys,

So I've had a DR650GW-2CH with front and rear cams installed.

Anyway I was running on a very old firmware version (1.xx) and it offered me v2.008 which I downloaded and upgraded (all over the latest iPad app) Anyway, long story short, I didn't realise that v2.008 did not support 2 channel recording. :(

Downgraded to v2.007 as recommended, and it still wont see the rear camera, even though Ive confirmed 2.007 is loaded and running.

Can anyone point me in the right direction or recommend if I should downgrade to an earlier version (and if so, which one?)

Many Thanks,
J.
 

JohnM

Active Member
Joined
Dec 6, 2015
Messages
197
Reaction score
31
Location
Lincs
Country
United Kingdom
Dash Cam
DR650GW-2CH
Hi JK

I've also seen somewhere on the forum that V2.008 does not support Rearview kit R100. This kit is an add-on that runs a reversing camera (I think). Are you getting confused with this when you say it doesn't support 2-channel recording?
 
OP
J

JKWelsh

New Member
Joined
Oct 6, 2013
Messages
15
Reaction score
1
Country
United Kingdom
Hi JohnM,

I have the original DR650-2CH, with a front and rear cam. This was working ok and recording on both channels up until l upgraded to 2.008, at which point only the front camera was recognised and recording. It doesnt even see the rear camera now.

I'll try your suggestion on going 1.011-->2.002-->2.007 and see if that kicks it back to life.

Cheers,
John.
 

Sugar Silva

Member
Joined
Mar 23, 2016
Messages
39
Reaction score
13
Country
United States
Correct, it won't support the rear cam add on but it DOES support the rear cam since you have the DR650GW-2Ch. I'm running it without issue on Either cam
 
OP
J

JKWelsh

New Member
Joined
Oct 6, 2013
Messages
15
Reaction score
1
Country
United Kingdom
@Sugar Silva

Ah, ok. Now the penny drops :eek:

So when I read the Blackview description of the 2.008 release (after finding the rear camera was no longer functioning) I thought it was due to 2.008 not supporting the R-100 option.

So the actual issue is more likely to have been caused by upgrading directly to 2.008 instead of taking a stepped approach and going through some of the previous releases, before then installing 2.008??

I wish Blackvue had made that clear instead of just pushing me directly to 2.008 on the iPad app. If regression to 1.011, followed by 2.02 then 2.0o7 (or 2.008?) fixes the issue great. If not I will be contacting Blackvue direct and taking it up with them.

Thanks for your advice guys, I'll report back here if I successfully restore functionality :)
 
Last edited:
OP
J

JKWelsh

New Member
Joined
Oct 6, 2013
Messages
15
Reaction score
1
Country
United Kingdom
Well mystery solved!

After going through the 3 step firmware upgrade, it still wasn't working.

After trawling the Internet, a post mentioned checking the rear cam was getting power (l had taped over the rear cam LED as it was distracting at night)

No power! On closely inspecting the rear cable, l found the centre pin broken off and stuck in its socket. Doh....


Also received an email from BlackVue telling me that my DR650GW is not capable of Cloud options as the model build is too old, so have purchased a DR650S which is!

Thanks again guys.
John.
 

Similar threads


Top