DR900S Just Stopped

Freewuns

New Member
Joined
Jun 21, 2019
Messages
2
Reaction score
0
Location
Maroochydore
Country
Australia
Dash Cam
DR900S-1CH
I just went to check some video on my cam and when I checked the video files it looks like it hasn't recorded for about a week. When I power the unit up it just sits there with only the front white LED blinking. I formatted the SD Card using the PC based software (so its FAT32) and then installed the latest firmware to the SD Card. Powered up and is still doing the same thing.

I have tried a different SD Card with the same results and with no SD Card. White blinking LED is it and nothing else.

I went to the auto shop I got it from and they said there might be a fix but the techs in Perth don't work on a weekend so I have to wait.

Is there a factory reset on this unit (not wifi) that will reset the whole unit to factory settings and thus get the boot cycle complete that anyone knows of?

TIA
 

BlackboxMyCar

Well-Known Member
Retailer
Joined
May 21, 2014
Messages
840
Reaction score
411
Location
Vancouver, BC
Country
Canada
Dash Cam
Thinkware, BlackVue, IROAD, Viofo, BlackSys
Unfortunately, this is bricked and can't be fixed. There's no other factory reset available.
 

kamkar1

Well-Known Member
Joined
Oct 11, 2013
Messages
26,122
Reaction score
14,820
Country
Denmark
Dash Cam
10 years, many dashcams
And it is winter in AU :rolleyes: did you get to run it too over last summer ?
 
OP
F

Freewuns

New Member
Joined
Jun 21, 2019
Messages
2
Reaction score
0
Location
Maroochydore
Country
Australia
Dash Cam
DR900S-1CH
Bought it in Feb 2019 so had a bit of a summer and no issues. Only failed the other day. The Autobarn store is sussing out with the distributor in Perth if there is anything that can be done. As it's still in warranty Im not concerned.

Just a major peeve when you spend so much $$ on something like that. My last BlackVue lasted over six years.
 
Thread starter Similar threads Forum Replies Date
SR45 DR900S-1CH 4
alexsoll DR900S-1CH 26
Top