DRS650 won't boot

bsk997

New Member
Joined
May 16, 2019
Messages
2
Reaction score
0
Location
CA
Country
United States
Hi Guys,
I have a DRS650 2 channel that's been working fine for awhile now.
I had to get the windshield replaced and had to take down the cam. When I got the car back and plugged in the cam, it doesn't want to boot up. The only light I see turn on is the GPS light. No Wifi lights, no Rec lights, nothing. I took out the SD card, formatted it and put on the latest firmware as well just to test and still nothing. Also tried a couple of different SD cards as well.
I looked at the power cable and it still seems ok.
Are there any other troubleshooting or is this a brick now?
Thanks!
 

BlackboxMyCar

Well-Known Member
Retailer
Joined
May 21, 2014
Messages
850
Reaction score
423
Location
Vancouver, BC
Country
Canada
Dash Cam
Thinkware, BlackVue, IROAD, Viofo, BlackSys
Might be bricked, unfortunately.

It's not hardwired, correct? If it is, try the 12V cigarette adapter cable.

Try another cigarette socket if possible, as well.
 
OP
B

bsk997

New Member
Joined
May 16, 2019
Messages
2
Reaction score
0
Location
CA
Country
United States
Very weird that it would've been bricked. :(
Yeah, it's not hardwired. I tried it in another car as well.
Thanks for the reply!
 

BlackboxMyCar

Well-Known Member
Retailer
Joined
May 21, 2014
Messages
850
Reaction score
423
Location
Vancouver, BC
Country
Canada
Dash Cam
Thinkware, BlackVue, IROAD, Viofo, BlackSys
Yeah, unfortunately, sounds like it has met its end.

You didn't happen to order this from us, did you? We may be able to offer a repair service or upgrade, etc.

If not, you can also try emailing BlackVue directly and inquire if they have options for you. Send your serial number and issues to cs@pittasoft.com.
 
Top