Firmware update to support IMX291 rear camera (SGR291CAM)

Paromkin

New Member
Joined
Nov 22, 2018
Messages
6
Reaction score
3
Country
United States
Hi, I've recently bought SGGCX2PRO with SGR291CAM from Amazon and received instructions to update firmware in order to support rear camera. I formatted memory card using camera and copied file LDGCX2P.bin to card. Inserted it into camera and turned it on however it didn't notice any update process. Camera just started auto recording.
How can I check if it was updated? It shows `GCX2P_20180920_V1.15` in a firmware section. Can I proceed to step 2?
P.S. I'm using OS X (10.14.1) to download file to card.
 
OP
Paromkin

Paromkin

New Member
Joined
Nov 22, 2018
Messages
6
Reaction score
3
Country
United States
Proceeding to step 2 updated firmware. Thank you.
 
OP
Paromkin

Paromkin

New Member
Joined
Nov 22, 2018
Messages
6
Reaction score
3
Country
United States
It shows X2PRO+181113V1.17 in `Firmware Version` but when I connect rear camera it doesn't record rear video. In Movie folder I see only files from front camera. I've reseted settings to default, formatted card and tried to restart camera but it didn't help. However camera sounds bip signal when I disconnect rear camera while recording.
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
52,478
Reaction score
30,315
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
Don't unplug the rear camera while it's recording

Do you see the PIP view of front and rear on the LCD?
 
OP
Paromkin

Paromkin

New Member
Joined
Nov 22, 2018
Messages
6
Reaction score
3
Country
United States
No, I don't see rear in PIP. Even if set to show rear camera in shows me front.
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
52,478
Reaction score
30,315
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
The default view is PIP so if you don't see that there's something not right

Did you buy direct or from Amazon?
 
OP
Paromkin

Paromkin

New Member
Joined
Nov 22, 2018
Messages
6
Reaction score
3
Country
United States
Wait, I figured out the issue. I was connecting camera to my Macbook and rear camera wasn't working. When I connected camera to regular power adapter rear camera started working.
Sorry for confusion.
 
Top