Geko Orbit 530 - couple of issues

Perrico

New Member
Joined
Mar 4, 2015
Messages
19
Reaction score
1
Country
Canada
Just wondering if anyone has used the Geko Orbit 530. I don't see a Geko section but they are the same company as Papago.
I've used it for several days now. I am actually on a second unit because I returned the first one. While it checks a lot of buttons for me, I have two issues with the camera.

On the plus side, it
- has a screen
- has WIFI
- has what seems to be a decent app
- comes with an adhesive AND suction mount (suction mount looks to be pretty strong too)
- has 1296P

The issues I have are the following
- the 1296 is 1768 x 1296 which is a 4:3 aspect ration - ie NOT widescreen. The image also looks horizontally compressed using this mode. Cars look squished. I don't get why they would use this boxy shape ratio. Almost defeats the purpose of the higher resolution.
- the other issue I have is that even with it set to record at 5 min lengths, the camera can save videos of any and all different lengths - 13 seconds, 3 minutes, 2 minutess, ... anything under 5 min.
- there can be missing footage - I have seen gaps from the end of one video to the start of the next video form 1 second to as much as 30 seconds.

Because of the issues, I returned the first unit. I did test the camera with supplied 16 Toshiba Gig SD as well as my own Kingston 32 Gig SD. The issue seemed to be only with the supplied SD.
The camera went on sale again for $40 off so I decided to give it a 2nd chance. I was still seeing the odd video time lengths. I ended up testing it on the 8 Gig SD that came with my Papago S37 as well as my own Kingston 32 Gig SD. Got the same results on all SD cards. From what I recall, the camera did seem to be more stable at recording proper 5 min videos if the camera was not moving - ie just left on a table to record. In an actual car, I would get anything but 5 minutes. I was also still seeing 1 or 2 second gaps between video files.

I contacted customer service. They are looking into it. The service is actually really good.
I have a few days left to decide if I want to keep this so wondering if anyone else has seen these issues.

The reviews are really good on the Best Buy website but I wonder if those people see this issue with video length and the gaps.
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
47,410
Reaction score
25,945
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
memory card is the other possible cause but it looks like you've tried a few different ones already, this range comes out of a different factory to the normal Papago models, not sure what their quality is like, maybe you just got a bad one
 

SawMaster

Well-Known Member
Joined
Apr 10, 2015
Messages
5,638
Reaction score
5,092
Location
SC
Country
United States
Dash Cam
G1W-S, G1W-HC, G1W clone, B1W, N2 Pro, K2S, B2W, (ex Mobius)
I'd try setting to a shorter file time. Some other cameras only work well with specific times while some seem to work with any. I haven't found any pattern to this, only noticing that sometimes it will make an unreliable cam work reliably.

Phil
 
OP
P

Perrico

New Member
Joined
Mar 4, 2015
Messages
19
Reaction score
1
Country
Canada
Interesting. It doesn't necessarily give me comfort but perhaps being less data to write to the SD somehow makes it less unstable? Just a guess.
Thanks
 
Thread starter Similar threads Forum Replies Date
BCHobbyist PAPAGO 6
BCHobbyist PAPAGO 0
B PAPAGO 6

Similar threads


Top