Issue with Cellink Neo EXT7

SirCozak

New Member
Joined
Aug 5, 2018
Messages
17
Reaction score
11
Country
United Kingdom
Hi Everyone

I'm looking for some advice regarding a Cellink Neo 7 Ext battery pack. I have Neo 6 battery pack as my main unit, purchased about 6 months or so ago. It is hardwired in and set to 9amps, and that works perfectly fine with it charging up when the ignition is on and then going into parking mode when the engine is off.

I recently wanted to extend my parking mode runtime so I purchased the Neo Ext 7 expansion battery to add to my Neo 6. However there appears to be an issue in that it simply doesn't charge. I was thinking at first that it was faulty and was planning on returning it for a replacement. However I have noticed some differences between the website images of the Neo 7 Ext Battery and the unit I have received. On the website images the Ext7 has two yellow input/output connectors only, and these match the single yellow ext batt connector on the main Neo 6 unit. However on Ext7 battery pack I have received it has an orange connector on the left and the yellow one on the right. It also has a usb port and a charging/discharging indicator led in the middle. The orange connector is actually 3 pin, with the third pin being in the place where the notch at the top of the yellow connector usually sits. So it appears to be of a completely different design. The connector cable that came with the Ext7 also has a 3rd cable, so clearly this third pin is meant for something. I am wondering if the Ext7 has been redesigned and is not compatible with Neo 6 I purchased 6 months ago due to this 3rd pin. The Ext7 also didn't come with instructions, so I'm unsure which connector should be connected to the main unit, although the charge light doesn't come on regardless of which one I connect it up to.

Does anyone know if this seemingly redesigned Ext7 works with the Neo 6 that has the yellow ext batt connector? I'm trying to decide if I should just get a refund as I don't want to request a replacement to then just have the same thing happen again due to incompatibility.

Any help is most appreciated!
 

maus1975

New Member
Joined
Apr 12, 2021
Messages
3
Reaction score
0
Location
Rotterdam
Country
Netherlands
Hi,

I've had serious problems with the old cellini neo ext7. I've had 2 old versions, who didn't work with mij neo6. De new version was send to me almost full with juce.
On the new version you will also vind a on/off switch. I assume you set the switch to on? When I switch the battery on the led was turning on imidiately.
My new ext7 is loading with and without the 3rd pin cable. Is can even load under 5 amps. The new cable also fits in my older neo6.

Good luck.
 
OP
S

SirCozak

New Member
Joined
Aug 5, 2018
Messages
17
Reaction score
11
Country
United Kingdom
There is no on/off switch on mine at all. It's got no charge at all, I removed it from the car earlier and plugged my mobile phone into the usb port to see if it would charge and nothing.

Below is what it looks like, note the metal pin on the orange connector along the top. The yellow connector has not such pin, and the notch at the top is just plastic. If anyone has the version below working with a Neo 6 with the yellow ext batt connector please let me know.


Cellink.jpg
 

maus1975

New Member
Joined
Apr 12, 2021
Messages
3
Reaction score
0
Location
Rotterdam
Country
Netherlands
I have a new version, just got in today. Cellink is delivering them this month. I've had 2 batteries. Both didn't work, just like you. Problems with the first start. The dealer delivered me this new version.IMG_20210412_225155.jpg
 
OP
S

SirCozak

New Member
Joined
Aug 5, 2018
Messages
17
Reaction score
11
Country
United Kingdom
Thanks, mine lacks the switch, perhaps this one I have is just broken. Can you confirm if you have yours connected to a Neo 6 that has the yellow ext batt socket?
 

Tips

New Member
Joined
Apr 28, 2021
Messages
4
Reaction score
3
Location
Scotland
Country
United Kingdom
I am having issues as well with these batteries. I have 2 EXT7+ batteries and the LED blinks red then nothing when I plug the cable into it (either port). The ones I have received both came with the orange port and the connector with 3 cables. They are connecting to a EXT6. I thought maybe dodgy LEDs on the batteries but when I set the app to the higher capacity the camera dies at 50%. I have tried plugging the EXT7+ into a home charger which powers the EXT6 fine but get the same result with the LED flashing red for a split second.

I noticed the unit posted above as a on/off switch which none of mine have.
 
OP
S

SirCozak

New Member
Joined
Aug 5, 2018
Messages
17
Reaction score
11
Country
United Kingdom
Mine was exactly the same, red led flashes for a split second when the charge cable was disconnected. I sent it back in the end and it was confirmed as dead. Decided to get a refund and wait a bit to ensure when I do get another it's the one with the switch as per the above which seems to be of a newer design.
 

maus1975

New Member
Joined
Apr 12, 2021
Messages
3
Reaction score
0
Location
Rotterdam
Country
Netherlands
Thanks, mine lacks the switch, perhaps this one I have is just broken. Can you confirm if you have yours connected to a Neo 6 that has the yellow ext batt socket?
Hi, I can confirm that I have a Neo6 with a yellow ext battery socket. I also can confirm that the new version of the ext7 works flawless
 

Tips

New Member
Joined
Apr 28, 2021
Messages
4
Reaction score
3
Location
Scotland
Country
United Kingdom
Received today from Amazon UK directly.

EXT7+ with on/off switch which after 2 previous batteries being faulty i have got lucky and got the latest batch

EXT7+ and Neo6 both working as they should.

Even the cellink support in UK (NWX) are clueless.

Firstly they never knew 6800Mah batteries existed.

They never knew about a new batch with on/off switch.

They had my neo6 and ext7+ in their office and claimed worked fine blaming operating temperatures etc etc, when the car electricians who installed my setup confirmed more than once the ext7 was dead. Luckily I bought direct from Amazon.

received_907941386439260.jpg
 

Zed333

New Member
Joined
Nov 13, 2019
Messages
8
Reaction score
2
Location
London
Country
United Kingdom
Hi guys, hope someone can help, I’ve decided to return my ext7 pack, as above I called up cellink support in UK (NWX) and as above they were clueless and not much help, I’ve decided to return my ext7 pack as non of the led lights work so I’m assuming mine is defective to however I’m finding it near impossible to find a carrier to ship the lithium batteries as they are “dangerous goods” can someone advise on a carrier that will ship these back to Amazon
Amazon.co.uk Customer Returns
Amazon Way
Dunfermline
Fife
KY118ST

Please your help would be greatly appreciated
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
52,478
Reaction score
30,314
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
airfreight is a problem, did you check with the post to see if they offer a ground service only to that destination?

next option is talk to Amazon again, they obviously had a carrier that would ship it to you
 

Tips

New Member
Joined
Apr 28, 2021
Messages
4
Reaction score
3
Location
Scotland
Country
United Kingdom
Hi guys, hope someone can help, I’ve decided to return my ext7 pack, as above I called up cellink support in UK (NWX) and as above they were clueless and not much help, I’ve decided to return my ext7 pack as non of the led lights work so I’m assuming mine is defective to however I’m finding it near impossible to find a carrier to ship the lithium batteries as they are “dangerous goods” can someone advise on a carrier that will ship these back to Amazon
Amazon.co.uk Customer Returns
Amazon Way
Dunfermline
Fife
KY118ST

Please your help would be greatly appreciated
Just send it via royal mail. That's what I done with mine. Just don't put the battery warning label on box.
 

Zed333

New Member
Joined
Nov 13, 2019
Messages
8
Reaction score
2
Location
London
Country
United Kingdom
airfreight is a problem, did you check with the post to see if they offer a ground service only to that destination?

next option is talk to Amazon again, they obviously had a carrier that would to ship it to you
Hi, yes spoke to Amazon customer services on a number of occasions
They’ve sent me a number of carriers but every time you read the terms and conditions it lists they don’t ship
So now I’m going round in circles and trying to find out what is the best way forward
 

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
283
Reaction score
221
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
I've just received yesterday the EXT7 battery from Amazon Spain..It came completely discharged and is the old model 6600mAh with two yellow connectors(no switches,no USB plug)..I have charged it in my house connected to the main Neo 6 unit,then connected them in my car to A129 Pro Duo cameras and it shows between 48-50 hours remaining(in low bitrate parking mode FHD+FHD)..I think I'm good to go.20210626_192046.jpg
 
Last edited:
Top