Power Magic Pro Either Set on or off , switches off after I remove the key from ignition

Discussion in 'Power Magic Pro' started by george241208, Feb 14, 2016.

  1. george241208

    george241208 New Member

    Messages:
    12
    Likes Received:
    0
    Country:
    United Kingdom
    I would really appreciate any king of advice on this.
    Either when I set the power magic pro on off or on it switches off as soon as I do remove the key.
    Rarely It does stay on and records.
     
  2. jokiin

    jokiin Well-Known Member Manufacturer

    Messages:
    36,023
    Likes Received:
    18,106
    Location:
    Shenzhen, China - Sydney, Australia
    Country:
    China
    Dash Cam:
    Too many ¯\_(ツ)_/¯
    check your voltages at the point where you've pulled power from
     
  3. george241208

    george241208 New Member

    Messages:
    12
    Likes Received:
    0
    Country:
    United Kingdom

    I called a specialist from blackvue and voltages, cables are correct. Still though the camera when set to I switches off when I remove the key from the ignition
     
  4. jokiin

    jokiin Well-Known Member Manufacturer

    Messages:
    36,023
    Likes Received:
    18,106
    Location:
    Shenzhen, China - Sydney, Australia
    Country:
    China
    Dash Cam:
    Too many ¯\_(ツ)_/¯
    what voltage did you measure at the connection point?
     
  5. CDNinHH

    CDNinHH Active Member

    Messages:
    518
    Likes Received:
    176
    Country:
    Thailand
    Dash Cam:
    A118C MG600G (JooVuuX returned)A119 Shadow 1S
    How did you tap into a "live" circuit? If you used a fuse tap have you checked the fuses in that? It sounds like the ACC circuit is fine if the camera works while the car is on, so the fault must be in the HOT circuit....unless the PMP is a dud.
     
  6. Ralph2

    Ralph2 Active Member

    Messages:
    610
    Likes Received:
    165
    Location:
    Edmonton AB
    Country:
    Canada
    Dash Cam:
    BlackVue 650GW in 2011 Highlander
    I agree with CDinHH and suspect your source of "always on" power. Confirm you have power from the connection you wired the yellow wire to when the key is off.. for several moments.. some cars seem to have a delay on some circuits.
     
  7. CDNinHH

    CDNinHH Active Member

    Messages:
    518
    Likes Received:
    176
    Country:
    Thailand
    Dash Cam:
    A118C MG600G (JooVuuX returned)A119 Shadow 1S
    Hey Ralph, that's CDN as in Canadian ;)
     
    Ralph2 likes this.
  8. jokiin

    jokiin Well-Known Member Manufacturer

    Messages:
    36,023
    Likes Received:
    18,106
    Location:
    Shenzhen, China - Sydney, Australia
    Country:
    China
    Dash Cam:
    Too many ¯\_(ツ)_/¯
    HH the Hanoi Hilton?
     
    CDNinHH likes this.
  9. CDNinHH

    CDNinHH Active Member

    Messages:
    518
    Likes Received:
    176
    Country:
    Thailand
    Dash Cam:
    A118C MG600G (JooVuuX returned)A119 Shadow 1S
    Well that would be Vietnam, but good guess. Check a map for a place about 150 kms or so SW of Bangkok
     
  10. jokiin

    jokiin Well-Known Member Manufacturer

    Messages:
    36,023
    Likes Received:
    18,106
    Location:
    Shenzhen, China - Sydney, Australia
    Country:
    China
    Dash Cam:
    Too many ¯\_(ツ)_/¯
    was trying to think of it, there was a knick name associated but couldn't think what it was, that was the first one that came to mind
     
  11. JohnM

    JohnM Active Member

    Messages:
    187
    Likes Received:
    31
    Location:
    Lincs
    Country:
    United Kingdom
    Dash Cam:
    DR650GW-2CH
    Hi George. I connected my live yellow wire to the "emergency lamps", the 4-way flashers fuse, using the "add a fuse" connection.

    Regards

    John
     
  12. george241208

    george241208 New Member

    Messages:
    12
    Likes Received:
    0
    Country:
    United Kingdom
    Hi, an update,
    I have removed the power magic pro, and still I m having problems with the camera.
    It keeps restarting itself more than 3 -4 times on an hours trip.
    I did call blackvue UK since they had a look at the installation initially,and they did ask me to install the firmware with a mini SD card of less than 16GB.
    And I did so. I am using a 128GB recomended by them , a Delkin card , before I was using a sandisk 128GB. But still I am getting problems with it, as well as with smaller cards.
    I do believe that the problems are firmware related but I would need your help in here and It would be much appreciated.
     
  13. george241208

    george241208 New Member

    Messages:
    12
    Likes Received:
    0
    Country:
    United Kingdom
    I am using only the cigarette lighter connection
     
  14. Hillbilly

    Hillbilly Well-Known Member

    Messages:
    1,548
    Likes Received:
    220
    Country:
    Australia
    Format the card in the camera and see what happens Which model camera is it and what car are you installing it in
     
  15. george241208

    george241208 New Member

    Messages:
    12
    Likes Received:
    0
    Country:
    United Kingdom
    DR 650 GW , I did format it but had the same result. Its on a Vauxhall vectra.Since now the only connection is the cigarette lighter I do believe that the problem is the firmware.
     
  16. jokiin

    jokiin Well-Known Member Manufacturer

    Messages:
    36,023
    Likes Received:
    18,106
    Location:
    Shenzhen, China - Sydney, Australia
    Country:
    China
    Dash Cam:
    Too many ¯\_(ツ)_/¯
    If the power supply is solid and you're using the supplied memory card and still have issues then it's quite possibly just a hardware problem, it happens with any brand unfortunately
     
  17. george241208

    george241208 New Member

    Messages:
    12
    Likes Received:
    0
    Country:
    United Kingdom
    Is it repairable or just buy another one?
     
  18. george241208

    george241208 New Member

    Messages:
    12
    Likes Received:
    0
    Country:
    United Kingdom
    When I firstly used the camera for couple of months it didnt have this problem.It all started after firmware updates.
     
  19. jokiin

    jokiin Well-Known Member Manufacturer

    Messages:
    36,023
    Likes Received:
    18,106
    Location:
    Shenzhen, China - Sydney, Australia
    Country:
    China
    Dash Cam:
    Too many ¯\_(ツ)_/¯
    You would still be covered under warranty wouldn't you?
     
  20. JohnM

    JohnM Active Member

    Messages:
    187
    Likes Received:
    31
    Location:
    Lincs
    Country:
    United Kingdom
    Dash Cam:
    DR650GW-2CH
    Hi George

    Have you tried going back to the previous firmware version?
     
Loading...

Share This Page