RAW photos from Z26L / firmware 1.5.6 coming out purple

Discussion in 'Yi Action Camera' started by DSun, Aug 20, 2017.

  1. DSun

    DSun New Member

    Messages:
    2
    Likes Received:
    0
    Country:
    United States
    Hi all,

    I recently bought a Xiaomi Yi and was trying to develop RAW photos, however, the photos come out with a really strong purple cast in Lightroom (see attached [​IMG]). I activated RAW image file creation using:

    #Reduce noise reduction as much as possible
    t ia2 -adj tidx -1 -1 -1

    #Create RAW files
    t app test debug_dump 14

    I converted the RAW files to DNG with the following settings:

    ;config by nutsey
    31850496, 0, 4608, 3456, 7, 9216, 16, 4, XIAOMI-YI

    ...and then drag-and-drop the resultant .DNG file into a batch file with exiftool in the same folder. The batch file contents are;

    @echo off
    setlocal enableextensions enabledelayedexpansion
    SET /A COUNT=1
    if [%1]==[] goto :eof
    :loop
    exiftool -WhiteLevel=1024 -BlackLevel=50 %1 -overwrite_original
    ECHO !COUNT! file(s) processed.
    SET /A COUNT+=1
    shift
    if not [%1]==[] goto loop

    Any ideas on what I can do to fix the purple cast?

    Thank you

    EDIT: attached image
     

    Attached Files:

    • LR.png
      LR.png
      File size:
      546.9 KB
      Views:
      5
  2. M2N

    M2N New Member

    Messages:
    2
    Likes Received:
    0
    Country:
    Brazil
    +1

    Same issue.
     
  3. M2N

    M2N New Member

    Messages:
    2
    Likes Received:
    0
    Country:
    Brazil
  4. DSun

    DSun New Member

    Messages:
    2
    Likes Received:
    0
    Country:
    United States
    Thank you!
     
Loading...

Share This Page