segment display

mfbyrd1231

New Member
Joined
Mar 21, 2015
Messages
22
Reaction score
5
Country
United States
Has anyone experienced a dead segment in the segment display?
 

Lawkoh

New Member
Joined
May 3, 2015
Messages
25
Reaction score
6
Country
Singapore
Yes.
I am getting it now
And it's getting worst
Segment is not really dead. It's random
Likely is a firmware issue
 
OP
mfbyrd1231

mfbyrd1231

New Member
Joined
Mar 21, 2015
Messages
22
Reaction score
5
Country
United States
Mine is completely unreadable now. Mostly the two segments on the left. Upgrading firmware hasn't helped.
 

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,060
Reaction score
1,718
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
What segment display?
 
OP
mfbyrd1231

mfbyrd1231

New Member
Joined
Mar 21, 2015
Messages
22
Reaction score
5
Country
United States
Where the time and such is displayed on the back of the front camera.
 

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,060
Reaction score
1,718
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
Oh the LED's may have burned out.
Not sure how hard to replace them as need to take it apart.
 
OP
mfbyrd1231

mfbyrd1231

New Member
Joined
Mar 21, 2015
Messages
22
Reaction score
5
Country
United States
I would assume you would have to replace the entire segment. Assuming that is actually whats "under the hood". Luckily its not really a necessity. However it would be useful during a firmware update...
 

VitaliyK

New Member
Joined
Apr 4, 2019
Messages
2
Reaction score
0
Country
Canada
I bought new from Arrow and replaced. Problem solved.
 
Top