SG9665GC V1 corrupts last file (solved)

Hex

Member
Joined
Dec 13, 2015
Messages
18
Reaction score
40
Country
Germany
Dash Cam
SG9665GC
Hello again,

I had troubles with corrupt files with my SG9665GC V1 and thought sharing it here might be useful if someone has the same error.

So what happened?
I wanted to browse the recordings but every file smaller than 345+ MB was corrupt and could not be displayed with VLC or RegistratorViewer. These are the files generated just before the power to the cam was turned off. I don't know if it was just coincidence, but the corrupt files started apper from 1st august. Until 31st july everything was fine.

The Symptoms
The Camera is booting and recording normally. The only strange thing are the [X] displayed at the bottom of the LCD and of course the corrupt files.


When power was disconnected the LCD backlight did not switch off immediately but was getting dimmer and switching off with a few seconds delay. The REC-led continued to blink a few seconds until the power LED got dimmer. It took a few more seconds until the power-led went completely off. I tried different µSD-cards but no avail. To get in the menu it took some time because the buttons responded very slowly.
As you probably know, I modded my SG9665GC (See here https://dashcamtalk.com/forum/threa...wn-and-some-emi-measurements-shielding.29448/) and suspected an hardware failure caused by my mod and thus the cam not detecting the missing power.

The solution
After browsing dashcamtalk for similar errors I noticed the area where the X are displayed the Car.No. should be (Hint: A full explanation what the SG9665GC can show on the LCD would be great in the manual). Unfortunately the menu did not let me to set the Car.No., every character was a space or blank.
I also noticed the timezone was on default (+10) but everything else still like I had set it.

I tried to reset the default settings in the settings menu but it did not get rid of the corrupt files and the Xes. It took three times to set the default settings (each a day or so apart) until the X-es disappeared and the camera not producing corrupt files.
Now the camera is working fine again, the only error which still remains are the blank characters for the Car.No. It's no problem because I dont need them anyway. Now also the LEDs switch off simultaneously a few seconds after the power has been disconnected and the menu is working fast again.


Any idea why this error happened and needed multiple resets is highly appreciated.

regards
Hex
 

niko

Well-Known Member
Retailer
Joined
May 1, 2013
Messages
10,610
Reaction score
6,503
Location
Dublin
Country
Ireland
Dash Cam
Street Guardian UK / EU / EEA Distributor
Try to re-install firmware.
 
Top