danmag

New Member
Joined
Feb 12, 2016
Messages
2
Reaction score
0
Country
Germany
Hey to all,

I have a sj5000 plus and a problem after the newest update, it's not possible to switch the camera on.
I already tried it without battery, without sd card, connected to the charger and so on.
The only thing is that the red charging lamp is on when the cam is connected to the charger with battery inside. Whitout battery the lamp is just blinking.

I hope some of you are able to help me.
Thanks
 

tgrdrgrss

Member
Joined
Nov 7, 2014
Messages
98
Reaction score
28
Location
Jakarta, Indonesia
Country
Indonesia
Dash Cam
Tronsport SJ4000; SJCAM SJ5000+, SJCAM SJ5000X Elite, K6000
Try the trick here http://techtronic9000.blogspot.co.id/2015/07/recover-bricked-sj5000.html
I've successfully brought back a couple of SJ5000+ with that trick.
Hey to all,

I have a sj5000 plus and a problem after the newest update, it's not possible to switch the camera on.
I already tried it without battery, without sd card, connected to the charger and so on.
The only thing is that the red charging lamp is on when the cam is connected to the charger with battery inside. Whitout battery the lamp is just blinking.

I hope some of you are able to help me.
Thanks
 
OP
danmag

danmag

New Member
Joined
Feb 12, 2016
Messages
2
Reaction score
0
Country
Germany
Thanks for the answer but it doesn't work anyway. My computer didn't recognise the cam (direct USB says: found 0 ambassador device!)

I was holding the button for 1-2 minutes, but nothing happened.

Any other ideas?
 

tgrdrgrss

Member
Joined
Nov 7, 2014
Messages
98
Reaction score
28
Location
Jakarta, Indonesia
Country
Indonesia
Dash Cam
Tronsport SJ4000; SJCAM SJ5000+, SJCAM SJ5000X Elite, K6000
The most important thing is to make sure the camera is detected and the driver is installed on the computer.
Steps to follow:
Install SJ5000 Plus driver on your PC:
1. Remove camera battery.
2. Press and keep it pressed Up Button.
3. Connect Micro USB cable to the camera and the PC.
4. You will seen and hear a windows sound / notification of it founding new hardware.

The most important part is that you
1. Remove the camera battery
2. Keep pressing the UP BUTTON while connecting the USB cable to the PC.

When all is still fail, you can always try to:
1. Use different computer
2. Use different USB Port
3. Use different USB Cable

Good luck!

Thanks for the answer but it doesn't work anyway. My computer didn't recognise the cam (direct USB says: found 0 ambassador device!)

I was holding the button for 1-2 minutes, but nothing happened.

Any other ideas?
 

TonyCams

Well-Known Member
Manufacturer
Joined
Aug 11, 2015
Messages
1,867
Reaction score
485
Country
China
Thanks for the answer but it doesn't work anyway. My computer didn't recognise the cam (direct USB says: found 0 ambassador device!)

I was holding the button for 1-2 minutes, but nothing happened.

Any other ideas?

Maybe try connecting to another computer's USB port or connecting to a high-speed USB hub.

If this does not work, please open a ticket or try our support forums.
 
Top