"t app key shutter" stopped working? (autoexec timelapse at boot)

nOerkH

New Member
Joined
Mar 10, 2018
Messages
4
Likes
0
Country
Austria
#1
Hi all together,

I've been reading in this incredible valuable forum for a while now, I even got my autoexec.ash up and running quite good with all the information found here. But now I'm totally stuck. Hopefully you can still assist here...

My plan is to automatically start jpg captures for a long timelapse when the camera is turned on, these pictures are pulled from the cam's FTP automatically (which is all working fine so far, just have to figure out how to clean up the SD card from the already downloaded jpg's and schedule capturing during daytime only, but the important topic first...)

my autoexec.ash contains these simple lines:

while true
do
t app key shutter
sleep 16
done


which is working fine, but just for about 4 to 5 pictures, then the cam simply stops capturing pictures. The script is still running (which is noticeable when you add beeps to it).
also tried to outsource the loop in another .ash (or .sh) file which is called from the autoexec.ash - same behaviour.
Changing the sleep time also makes no difference.

Adding a "t app key shutter" with and without sleep inbetween also leads to the same exhausting result -> a hand full of pictures taken, nothing more.

Besides some inspiration how to proceed I'd be happy to know if there is some kind of logging which can be checked? All this try and error makes me go nuts ...

every input is appreciated
 

nutsey

Active Member
Joined
May 12, 2015
Messages
345
Likes
156
Country
Turkey
#2
Your camera enters low-power stanby mode after 1.5 minutes of user inactivity as it does not recognize any script commands to be user interactions.

Use something like:
sleep 10
t app key shutter
sleep 6
reboot yes
 
OP
OP
N

nOerkH

New Member
Joined
Mar 10, 2018
Messages
4
Likes
0
Country
Austria
#3
Thanks for the reply,

initially I thought this does not really makes sense because

- the cam continues beeping (would it if it was in low-power standby?)
- even with sleep time set to 5 seconds its not more than 4 to 5 pictures taken (not gonna reach 1.5 minutes with that sleep time)

nevertheless I gave it a shot, my loop.ash now looks like this

while true
do
t pwm 1 enable
sleep 0.5
t pwm 1 disable
t app key shutter
sleep 30
reboot yes
done


result: I'm curious, the cam didn't reboot when I called the loop.ash with the command

d:/loop.ash

when these lines were entered in the autoexec.ash itself, well it did reboot but does this make sense? Should we call this a "solution"? Guess not ... (also wondering if this does extend the cameras live, since this program's gonna be running for like a year++)


.... while I was writing these lines some uncertain power finally got it working ... added these lines directly in the autoexec.ash ... going on for a few minutes now ...

while true
do
t pwm 1 enable
sleep 0.5
t pwm 1 disable
t app key shutter
sleep 0.5
t app key shutter rel
sleep 3


I haven't googled yet but is there a chance to implement some if-else conditions depending on the camera's local time?

like

if time < 06:00 or time > 18:00
do
sleep 1800
else
*timelapse script*


so that timelapse captures are only taken during daytime?
 

nutsey

Active Member
Joined
May 12, 2015
Messages
345
Likes
156
Country
Turkey
#4
You can try running a .SH script with
lu_util exec '<>'
command.
 

Similar threads

Top