USB file transfer causing camera to lock up.

David Bode

New Member
Joined
Sep 26, 2015
Messages
4
Reaction score
0
Country
United States
I got a Yi a week ago and have been very thankful for this forum. I was quickly able to install the hacked firmware and tweak some scripts to get the picture more to my liking.

Since I got the camera, I have not been able to transfer files from the USB port on the camera. I plug in camera, turn it on, files show up, try and drag them to computer, one file will start to transfer and then the camera drops the connection.

This action also causes the camera to lock up and become unresponsive. Buttons don't work. In order to restore functionality I have to pull the battery and re-boot it. Upon reboot the camera doesn't show up on computer when it is plugged in.

I just take the card out and plug that into my USB 3 card reader with the SD card adapter. The problem with this is that the card mechanism in the camera cannot be meant for several thousand cycles. Right?

Anyone have any experience with this?

Thanks!
 

Pvls

Member
Joined
Aug 26, 2015
Messages
63
Reaction score
13
Country
Poland
I got a Yi a week ago and have been very thankful for this forum. I was quickly able to install the hacked firmware and tweak some scripts to get the picture more to my liking.

Since I got the camera, I have not been able to transfer files from the USB port on the camera. I plug in camera, turn it on, files show up, try and drag them to computer, one file will start to transfer and then the camera drops the connection.

This action also causes the camera to lock up and become unresponsive. Buttons don't work. In order to restore functionality I have to pull the battery and re-boot it. Upon reboot the camera doesn't show up on computer when it is plugged in.

I just take the card out and plug that into my USB 3 card reader with the SD card adapter. The problem with this is that the card mechanism in the camera cannot be meant for several thousand cycles. Right?

Anyone have any experience with this?

Thanks!
I had similar problems with my camera at the beggining. Almost every time with USB transfer my camera was not responsive and i was forced to remove the battery.
The solution was to change the usb cable to longer one.
 

itzik

Member
Joined
May 5, 2015
Messages
67
Reaction score
5
Country
Israel
the problem is beacuse of you delteing files from camera manualy.

wipe your sd card threw camera. ---> take a few photo/video --> connect to pc and trasfer then. you will see it works fine.

as soon as you trasfer files from pc to camera or delte files from sd card threw pc. this problem starts.
 

benjos

Member
Joined
Sep 28, 2014
Messages
78
Reaction score
7
Location
Los Angeles
Country
United States
Dash Cam
Dome D201, Xiaomi Yi, Shadow Tec GT550W
I have the same problem of the Yi freezing/crashing when trying to open a file on the PC or when trying to use the Android WiFi to view a video. Instead of using the Yi to copy files to the PC, I eject the microSD card and plug it into my microSD card reader to copy it to the PC. I'm using the official firmware 1.2.13.
 

trackcam

New Member
Joined
Aug 29, 2015
Messages
2
Reaction score
0
Country
New Zealand
Any quality micro usb cable that came with your phone will fix it. Don't use usb extensions or hubs.
 

benjos

Member
Joined
Sep 28, 2014
Messages
78
Reaction score
7
Location
Los Angeles
Country
United States
Dash Cam
Dome D201, Xiaomi Yi, Shadow Tec GT550W
Thanks, I tried a different micro USB cable instead of the short one that came with the camera and then it worked. BTW, I am using a USB 3.0 hub with the short cable but the hub also has external power cord. I'm using a longer micro USB cable connected to the motherboard and it works.
 
OP
David Bode

David Bode

New Member
Joined
Sep 26, 2015
Messages
4
Reaction score
0
Country
United States
It looks like it really doesn't like a hub and extension cable, but will work directly with a short cable.... sometimes. First time I tried it, I had to pull battery again. Next time I started the camera without the battery. Then it worked.
 

water

New Member
Joined
Nov 22, 2015
Messages
5
Reaction score
1
Country
China
it is a bug, i have the same qustion
 

Similar threads


Top