VIOFO А119V3 FIRMWARE

mariomart

Active Member
Joined
Feb 28, 2013
Messages
335
Reaction score
156
Location
Western Australia
Country
Australia
Dash Cam
Viofo A119 V3, Viofo A119S V2, Mini0806 and Navman MiVue 530
This mod does not affect parking, everything should be OK
I wish I had such luck, but no joy.

Reinstalled twice, did factory default, applied the same settings I have used for years but got the same results, only worked under high sensitivity, but I wasn't prepared to have it running non-stop.

I'll try the next iteration of modded firmware in the future to see if things change.
 

Kremmen

Well-Known Member
Joined
Sep 14, 2017
Messages
2,013
Reaction score
1,084
Location
West London & Reading
Country
United Kingdom
Dash Cam
      Viofo A119 V2 Viofo A119 V3
Can you list your power source and relevant settings, maybe one rings a bell.
 

mariomart

Active Member
Joined
Feb 28, 2013
Messages
335
Reaction score
156
Location
Western Australia
Country
Australia
Dash Cam
Viofo A119 V3, Viofo A119S V2, Mini0806 and Navman MiVue 530
Can you list your power source and relevant settings, maybe one rings a bell.
As said previously all the settings were the same as previous firmware versions which I have been using successfully. The power hasn't changed as I'm using the official Viofo HK3. It could be anything, I just can't be arsed chasing it down when 2.4 works perfectly using the same settings/power. It could be my particular hardware revision, who knows?
 

vvs49

Well-Known Member
Joined
Jan 8, 2015
Messages
438
Reaction score
575
Country
Ukraine
As said previously all the settings
Does stock V2.5 20210715 work fine?
I checked the code again in the mod firmware, no, everything is ok there !!

I never use parking, so I can't tell you what is wrong with you !!
What codec do you have enabled or is it not important?
 

mariomart

Active Member
Joined
Feb 28, 2013
Messages
335
Reaction score
156
Location
Western Australia
Country
Australia
Dash Cam
Viofo A119 V3, Viofo A119S V2, Mini0806 and Navman MiVue 530
Does stock V2.5 20210715 work fine?
I checked the code again in the mod firmware, no, everything is ok there !!

I never use parking, so I can't tell you what is wrong with you !!
What codec do you have enabled or is it not important?
Yes, stock 2.5 was working fine with parking mode. I was using TS codec as recommended, but now gone back to mp4.

It's no big issue for me. I had another official firmware in the past (I can't remember which one, I think it was 2.0) which also gave me problems so I just waited until a newer one came out and that worked perfectly.
 

ds2010

Member
Joined
Oct 23, 2019
Messages
51
Reaction score
50
Location
Moscow
Country
Russian Federation
Yes, stock 2.5 was working fine with parking mode

My 2c worth:

1)
There potentially may be a confusion between the f/w versions: there was no formal stock v2.5 - the VIOFO official d/l page still only lists v2.4.
Version v2.5build20210715 has leaked out from one of the VIOFO's blog pages (namely: from HERE) and technically, it is not official. I guess that's what you guys call "stock", right?
Then, I know that Mr vvs49 did the few mods based on that firmware, and at least one of those mods did NOT work correctly in parking mode.
So, it is important to be sure that the right (working) BIN file is used for re-flashing - read on.

2)
How to identify the proper bin file that we need (I have also uploaded it to HERE , just in case):
- in the dashcam "Firmware version" menu item, is says that the version is "vvs49 M_2_715"
- the exact file size of the FWA119V3.BIN file (inside the ZIP archive) in bytes should be 2665756

I have just tried my A119v3 via HK3 with that very firmware above, and it worked just fine. Yellow cable state (12V/0V) properly controls entrance/exit to/from the parking mode. You can tell that by the pictogram in the left top cormer of the LCD screen.

3)
If that still doesn't work, maybe the settings are the culprit.
I have attached the known-good settings table from one of the web forums, and that's what I was using in my tests above.
mariomart, what parking mode are you using? Auto event detection (AED), Time Lapse or LowBitrate?
Maybe you can try the exact settings from that attached table, and if it works (and it should), if you need the PMode other than AED, just set it accordingly.
Oh, and also: after each new f/w load, all settings MUST be reset to their defaults via the menu action, before you then set them to your preferred values - I think you know that.

Hopefully this will work for you... and for anyone else with the similar issue, for that matter.
Good luck.
 

Attachments

  • MySettings.jpg
    MySettings.jpg
    390 KB · Views: 67
Last edited:

Kremmen

Well-Known Member
Joined
Sep 14, 2017
Messages
2,013
Reaction score
1,084
Location
West London & Reading
Country
United Kingdom
Dash Cam
      Viofo A119 V2 Viofo A119 V3
Just offloaded my latest .................

I think I've hit the sweet spot :

VVS Mod 205
2560x1080 @ 30fps
High Bitrate
EV 0
CPL fitted

Having looked at the footage the freeze frame capability, even right up to 60mph/97kph is the best so far.

My latest does need the lens moving up a fraction but being as I have a new car expected 7th Sep I'll wait until it's fitted in there as the windscreen angle may be different.
 

mariomart

Active Member
Joined
Feb 28, 2013
Messages
335
Reaction score
156
Location
Western Australia
Country
Australia
Dash Cam
Viofo A119 V3, Viofo A119S V2, Mini0806 and Navman MiVue 530
My 2c worth:

1)
There potentially may be a confusion between the f/w versions: there was no formal stock v2.5 - the VIOFO official d/l page still only lists v2.4.
Version v2.5build20210715 has leaked out from one of the VIOFO's blog pages (namely: from HERE) and technically, it is not official. I guess that's what you guys call "stock", right?
Then, I know that Mr vvs49 did the few mods based on that firmware, and at least one of those mods did NOT work correctly in parking mode.
So, it is important to be sure that the right (working) BIN file is used for re-flashing - read on.

2)
How to identify the proper bin file that we need (I have also uploaded it to HERE , just in case):
- in the dashcam "Firmware version" menu item, is says that the version is "vvs49 M_2_715"
- the exact file size of the FWA119V3.BIN file (inside the ZIP archive) in bytes should be 2665756

I have just tried my A119v3 via HK3 with that very firmware above, and it worked just fine. Yellow cable state (12V/0V) properly controls entrance/exit to/from the parking mode. You can tell that be the pictogram in the left top cormer of the LCD screen.

3)
If that still doesn't work, maybe the settings are the culprit.
I have attached the known-good settings table from one of the web forums, and that's what I was using in my tests above.
mariomart, what parking mode are you using? Auto event detection (AED), Time Lapse or LowBitrate?
Maybe you can try the exact settings from that attached table, and if it works (and it should), if you need the PMode other than AED, just set it accordingly.
Oh, and also: after each new f/w load, all settings MUST be reset to their defaults via the menu action, before you then set them to your preferred values - I think you know that.

Hopefully this will work for you... and for anyone else with the similar issue, for that matter.
Good luck.
Thank you for a some very good information.

So, 3rd times a charm.

I downloaded the modded firmware via your link, used the settings guide (only deviated for "Parking Recording Duration: 6hrs", "Record Audio: ON" and "Screen Saver: 15sec".

Happy to report that all is well and parking mode is working.

The settings I had used previously were the same as what the guide had, however the only difference was that I had been using TS video format which I think is what was causing the parking mode problem.

Thanks again, Cheers
 

ds2010

Member
Joined
Oct 23, 2019
Messages
51
Reaction score
50
Location
Moscow
Country
Russian Federation
Thank you for a some very good information.

So, 3rd times a charm.
No worries, m8. ;) Glad it all worked out in the end.

the only difference was that I had been using TS video format which I think is what was causing the parking mode problem.
Now that's interesting... Never seen that. I'd be more inclined to blame the wrong firmware version.
You know what? Can I please ask you to do us all a small favor: If your parking mode works OK now, just change the file type back to TS (don't change anything else in the settings) and see if that one setting stuffs up the parking mode operation. That'd be a very interesting finding...
I don't seem to see that effect here.
Thanks.
 

ds2010

Member
Joined
Oct 23, 2019
Messages
51
Reaction score
50
Location
Moscow
Country
Russian Federation
I think I've hit the sweet spot :

VVS Mod 205
2560x1080 @ 30fps
High Bitrate
EV 0
CPL fitted

Having looked at the footage the freeze frame capability, even right up to 60mph/97kph is the best so far.
Nice.
Is "VVS Mod 205" the same as "vvs49 v2.5 M_2_715" ?
Day or Night?
Was HDR set to ON ?
I take your "freeze frame capability" as a readability/recognition of the number plates when frame stepping during playback, is that correct?
Quite a few people report better image when 1080 vertical resolution is set, over say 1440. Beats me, honestly...
 

Kremmen

Well-Known Member
Joined
Sep 14, 2017
Messages
2,013
Reaction score
1,084
Location
West London & Reading
Country
United Kingdom
Dash Cam
      Viofo A119 V2 Viofo A119 V3
Not sure what the actual firmware version is but I know it's based on stock 2.5 I downloaded about 6th Aug.
HDR Off

Freeze Frame at 60mph / 97kph :

RAa7Kwf.jpg


Freeze Frame - closing speed about 100mph / 161kph :

jVp4FK1.jpg


Night not as sharp (50mph) :

uIRRWSW.jpg

kw4QGlx.jpg


Forget quality because it's resized but the widescreen :

EaaY33j.jpg


I'm happy though.
 
Last edited:

Cirrus

New Member
Joined
Jul 15, 2021
Messages
17
Reaction score
16
Location
Near the Germany–Netherlands border
Country
Netherlands
Dash Cam
Viofo A119 V3
I think I've hit the sweet spot :

VVS Mod 205
2560x1080 @ 30fps
High Bitrate
EV 0
CPL fitted
I also like above settings. Even without CPL filter (yet), I think this is the best that I've tried so far.

VVS Mod V2.5 20210715 (aka: VVS49 M_2_715)
HDR off
 
Last edited:

markus

New Member
Joined
May 18, 2021
Messages
24
Reaction score
7
Location
Toronto, Ontario
Country
Canada
Dash Cam
VIOFO A119 V3, 70mai Smart Dash Cam 1S
With HDR on, is the night time imagery sharper? I'd assume that if so, the daytime imagery would not be as sharp?
 

Kremmen

Well-Known Member
Joined
Sep 14, 2017
Messages
2,013
Reaction score
1,084
Location
West London & Reading
Country
United Kingdom
Dash Cam
      Viofo A119 V2 Viofo A119 V3
I won't be doing any night driving for some months so hopefully someone else can test.
 

Cirrus

New Member
Joined
Jul 15, 2021
Messages
17
Reaction score
16
Location
Near the Germany–Netherlands border
Country
Netherlands
Dash Cam
Viofo A119 V3
I haven't done any night driving with VVS Mod V2.5 20210715 yet either. I'm very pleased with it during daylight.
I've received the CPL filter and it removes virtually all dashboard reflections, which were bad without the filter.

Below frames from a clip using:
2560 x 1080 30fps
High Bitrate
EV 0
HDR off
CPL fitted

The frame at the right taken against the sunlight

20210902091459_000540.MP4_snapshot_01.14_[2021.09.02_13.30.34].jpg20210902112140_000558.MP4_snapshot_01.15_[2021.09.02_13.56.01].jpg
 
Last edited:

Kremmen

Well-Known Member
Joined
Sep 14, 2017
Messages
2,013
Reaction score
1,084
Location
West London & Reading
Country
United Kingdom
Dash Cam
      Viofo A119 V2 Viofo A119 V3
I think as much as we fiddle we currently have a good combination, your's is identical to mine.
 

kamkar

Well-Known Member
Joined
Oct 11, 2013
Messages
30,446
Reaction score
17,114
Country
Denmark
Dash Cam
10 years, many dashcams
Do the ppl modding firmware's say what changes they have made ? in case the brand want to do the same in the factory firmware's.
 

Kremmen

Well-Known Member
Joined
Sep 14, 2017
Messages
2,013
Reaction score
1,084
Location
West London & Reading
Country
United Kingdom
Dash Cam
      Viofo A119 V2 Viofo A119 V3
I seem to recall vvs did once or twice, but only high level.

The colour and freeze frame does seem better than stock
 
Top