WR1 Moron Mount

Wr1Camman

Member
Joined
Aug 15, 2017
Messages
61
Reaction score
5
Country
United States
As I mentioned in another thread I got my WR1 replaced because it would stop recording without giving me the beeping warning.

As I also mentioned, it came with a new different windshield mount. Instead of the small discrete square mount that worked perfectly, it came with an oval shaped mount that looks like a size 12 shoe stuck to the window. The ball that allows the camera to pivot to adjust the position is also bigger on the new mount, as is the part of the camera where the mount attaches, so you can't use the old mount with the new camera.

One day I decided to check the video and found the video was tilted sideways. I went to check the camera and it was completely loose in the mount. I tightened the mount. I drive 6 miles a day, 3 miles to and 3 mies from work. After one week I found the camera was again completely loose. I tightened it by hand as tight as I could but a week later it was the same result.

I finally took a pair of pliers to tighten it but after a certain point the nut just slips past the threads like it is stripped. So I tightened it just to the point before the nut slips and the camera still moves around easily. I suspect in a week it will be completely loose again. I would try to glue the nut but even at full tightness the camera still moves around too easily.

There was nothing wrong with the old mount. It was smaller, more discrete, and held the camera without loosening. Why was it redesigned? Why does Viofo hire morons?
 

Nigel

Well-Known Member
Joined
Jul 7, 2014
Messages
12,243
Reaction score
6,223
Location
Devon
Country
United Kingdom
Dash Cam
Gitup F1, A129, B1W, B2W
Try some thread lock, maybe on the ball as well as thread...
 

nrvous1

Active Member
Joined
Sep 4, 2017
Messages
240
Reaction score
96
Country
United States
I'm using the suction cup mount that originally came with my wr1. You can also try some Teflon plumbing tape that might help with the stripped threads.
 
OP
W

Wr1Camman

Member
Joined
Aug 15, 2017
Messages
61
Reaction score
5
Country
United States
Thanks guys for the tips. I will give them a try.

I see 22 and 23% 1 star reviews at Amazon for Viofo products. Bad company with bad products. Hope they go out of business.
 
OP
W

Wr1Camman

Member
Joined
Aug 15, 2017
Messages
61
Reaction score
5
Country
United States
I tried the teflon plumbers tape and the locktite but even at maximum tightness the camera moves around too easily. I did put locktite on the ball itself and adjusted the camera for the proper position. I will let it sit 24 hours to cure and report back after a week or two. Very poor design of the mount. I don't know why they changed it but it makes the dash cam worthless.
 
Thread starter Similar threads Forum Replies Date
J WR1 1
Top