Z7 dying already. Anyone else with these problems?

josb0513

New Member
Joined
Nov 26, 2014
Messages
1
Reaction score
0
Country
Canada
So, I got my Z7 about a week ago. From day1, I noticed screen flickering to white & green and created corrupted video files. Had to power off and back on to fix it. Had this symptom about 2 times within 5 days of use. Then yesterday the screen completely went black and won't turn on. I managed to get it back on after few hours and now all the video got deleted from the microSD card and left with one corrupted file.

Anyone else having these issues?
 

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,023
Reaction score
1,681
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
Mine is still working great since Aug 2014.
 
Last edited:

Yoramza

New Member
Joined
Feb 15, 2015
Messages
4
Reaction score
0
Country
Israel
I bought 4 units from Gearbest
1st unit the car charger was defected
2nd unit doesn't recognize when the car switched off
3rd unit came DOA (do not power on)
4th unit didn't arrive yet
I bought it from Gearbest and their customer support is horrible.

I wouldn't recommend this dashcam nor Gearbest
 

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,023
Reaction score
1,681
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
I bought 4 units from Gearbest
1st unit the car charger was defected
2nd unit doesn't recognize when the car switched off
3rd unit came DOA (do not power on)
4th unit didn't arrive yet
I bought it from Gearbest and their customer support is horrible.

I wouldn't recommend this dashcam nor Gearbest
Read my replies in other threads.
Repeating same thing over and over won't do any good.
Email @Gearbest from the 'Inbox' conversation here on the top right corner.
They are all celebrating Chinese new year so you won't get reply for a week or so.
 
Last edited by a moderator:
Top