B-124E not being detected?

RoadRage

New Member
Joined
Mar 31, 2019
Messages
11
Reaction score
0
Country
United States
Hi, on most days, it seems my B-124 and B124-E get me plenty of hours of juice. Somedays, suddenly my DR-900S 2ch shuts off and when I check the power, it's 0%, even though I had quite a bit of juice that morning. So, when I go to charge it, it jumps to 2%, eventually 26% or so after 30 minutes. Then I disconnect it (turn B-124 off) then turn it back on and suddenly my battery app shows it's in the 70s%. This leads me to believe for some reason the B-124E isn't always being activated. I'm assuming the B124 is drawn from first, then once that's out, then drawing from the B-124E begins.

At first I thought it was my camera draining the juice too much, but seeing the difference from 20's% suddenly to 70s% (about 50% increase) tells me that one of the batteries was still charged but wasn't "detected" and so the camera shuts off.

Any ideas on how to fix?

edit: I noticed that after charging from the 76% tonight, it got stuck at 99% at wouldn't budge. So I reset the app, and my phone, still 99% and the charge light on the battery itself still is lit red. I changed the capacity in the app to 6,000 mah, saved, and it still showed 99%. I changed it back to 12,600 mah and suddenly it's 49%. Now it's charging (61%) and climbing. So odd!
 
Last edited:

BlackboxMyCar

Well-Known Member
Retailer
Joined
May 21, 2014
Messages
745
Reaction score
357
Location
Vancouver, BC, Canada
Country
Canada
Dash Cam
Thinkware, BlackVue, IROAD, Viofo, BlackSys
Unfortunately, the information displayed in the app for these batteries may not be the most accurate. BlackVue is aware of this so hopefully, it's a software issue that can be updated in the future.

One way of knowing if both batteries are working or not is to drive at least 90 minutes so that both batteries achieve a full charge. Once done, your DR900S-2CH should last about 20-25 hours.
 
OP
R

RoadRage

New Member
Joined
Mar 31, 2019
Messages
11
Reaction score
0
Country
United States
I just had this happen again to my B-124 + B-124E. Charging up my batteries, it stalls at 99%. I entered the app, changed the capacity from 12,600 to 6,000, saved, exited, opened app and it said 99% charged. I change the capacity back to 12,600, saved, and now it's charging again (i.e. 51% and continuing. Last time I did this as described in my April 4th post above, it actually did reach 100%).

Does the battery app control how the batteries are charged? If the app is just misreading the battery duo as being just 1 battery (i.e. only seeing the B-124), but in reality both batteries are being charged, shouldn't the charge show well over 49% when I do the capacity changing fix described above? It seems to me the app is somehow communicating to the batteries and maybe incorrectly sending information that there is only one battery and so the b-124 isn't 'seeing' the b-124E?

I'll report directly to BackVue as well.
 

Nath

Active Member
Joined
Aug 8, 2017
Messages
242
Reaction score
99
Country
Germany
Dash Cam
Blackvue DR900S-2CH
Did you measure how much time it needs to reach a 100%(or 99%) after the “reset” of the capacity? And how much current it draws during that time?

I think it’s a lack of feedback from the B-124E which causes this (but at least the B-124 should be able to determine the status based on current draw). I doubt the app has anything to do about it except the changing the information about capacity.

BTW: One question because i don’t have the B-124E. Do you see the expansion module in the Scan list of the battery app (or in the bluetooth devices list of your phone) ?
 
Last edited:
Top