Blackvue DR650GW-2CH GPS Not Working V2.00

geeuk

New Member
Joined
Oct 3, 2016
Messages
2
Likes
0
Country
United Kingdom
#1
Hello,

I installed the Blackvue DR650GW-2CH today without any issues but the GPS does not seem work.

I tried removing the camera out of the car and outside to see if it's the windscreen effecting the gps signal but after waiting for 1 hour no signal came.

The Parking Mode was off and Normal recording was on all the time so I don't see no reason why its not finding any signals.

I searched online and I saw some people complaining about the v2.00 having issues with the GPS, I thought I will try upgrading the firmware to V2.07, after inserting the SD card with the firmware on it I get the following announcement "The version information is different.", I tried updating it using my phone, once it uploaded it to the blackvue, I rebooted the blackvue and still it has the old firmware.

Can someone please help me see if there is any solutions or even a way to update it to the latest firmware.

Thanks,
Gee
 

BlackboxMyCar

Active Member
Retailer
Joined
May 21, 2014
Messages
504
Likes
246
Location
Vancouver, BC.
Country
Canada
Dash Cam
Thinkware, BlackVue, BlackSys , LG Innotek, VIOFO, iROAD
#2
Hello,

I installed the Blackvue DR650GW-2CH today without any issues but the GPS does not seem work.

I tried removing the camera out of the car and outside to see if it's the windscreen effecting the gps signal but after waiting for 1 hour no signal came.

The Parking Mode was off and Normal recording was on all the time so I don't see no reason why its not finding any signals.

I searched online and I saw some people complaining about the v2.00 having issues with the GPS, I thought I will try upgrading the firmware to V2.07, after inserting the SD card with the firmware on it I get the following announcement "The version information is different.", I tried updating it using my phone, once it uploaded it to the blackvue, I rebooted the blackvue and still it has the old firmware.

Can someone please help me see if there is any solutions or even a way to update it to the latest firmware.

Thanks,
Gee
Perhaps try loading V1.011 (legacy firmware) and see if that addresses the issue. Also I would recommend doing it through the download on Blackvue's website
 
OP
OP
G

geeuk

New Member
Joined
Oct 3, 2016
Messages
2
Likes
0
Country
United Kingdom
#3
Perhaps try loading V1.011 (legacy firmware) and see if that addresses the issue. Also I would recommend doing it through the download on Blackvue's website
Hi, Thank you I installed the 1.011 firmware and it's all okay now with the gps working :).. Now I need to find the solution for bmw f30 battery discharge warning when stationary... Otherwise I am well happy with the camera.
 

Ralph2

Well-Known Member
Joined
Jun 9, 2015
Messages
814
Likes
257
Location
Edmonton AB
Country
Canada
Dash Cam
BlackVue 650GW in 2011 Highlander
#4
I decided a few days ago to make the leap from the 1.xx series to the latest 2.xxx. My GPS was spotty (observed by noting the lack of speed indicated).. at best before and now with V2.xxx it is even worse. There seems to be no rhyme or reason behind the times it does and does not connect to GPS. I takes anywhere from 2 to 30 minutes to connect so on some trips it never does.. Many trips it will drop out for a period of time.. then reconnect... or not.
GPS connection has been a problem from the start and my dealer had offered to replace it but somehow it seemed more trouble than what it was worth.. Now, a year later it is probably too late but has been a continuous source of annoyance... to the point of seriously considering chucking it... and the Blackvue brand.
 

Ian Mills

New Member
Joined
Jul 20, 2016
Messages
27
Likes
5
Country
Australia
#5
... my dealer had offered to replace it but somehow it seemed more trouble than what it was worth..
You should have taken that offer as you have a faulty camera - I have two and never have any GPS issues
 

Similar threads

Top