Issues with viewing GPS Data / Video on a PC


New Member
Feb 15, 2019
Reaction score
Dash Cam
ToGuard CE20 (broken), Viofo A119v3
I have downloaded the demo version of Dashcam Viewer and I have the paid version of DVPlayer (as I read it's working well with this cam and it's rather cheap)
I tried both and I have some strange issues:

- Some videos are not properly loaded in Dashcam viewer: the below window appears, though, after clicking on the OK and waiting for some seconds, the video is often loaded correctly


I also used DVPlayer and 90% of the times, it fails to load GPS data; sometimes, though, immediately or after one minute or so, GPS data (and speed) appear correctly.
It looks like there may be an issue in the files themselves, so I have checked them with ffmpeg:

ffmpeg -i 20220124074737_000011.TS

Input #0, mpegts, from '20220124074737_000011.TS':
  Duration: 00:03:00.00, start: 0.032000, bitrate: 26658 kb/s
  Program 1
    Stream #0:0[0x200]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuvj420p(pc, bt709, progressive), 2560x1440, 30 fps, 30 tbr, 90k tbn, 60 tbc
    Stream #0:1[0x201]: Audio: aac (LC) ([15][0][0][0] / 0x000F), 32000 Hz, mono, fltp, 104 kb/s
  No Program
    Stream #0:2[0x300]: Unknown: none

I tried to extract Stream #0:2 but I cannot find the right command. Do you see something different in your files? Is there something I can do to improve the situation?
The video works well, but of course, a map view would be quite important as well.

If its any help here is the Codec pack I recently installed on my new PC and Dashcam Viewer works perfectly with my V3 :

>> Codec Pack Lite <<

It may not be the latest ? but it works.
Well, I gave it another try with DVPlayer and found out that GPS data gets actually loaded, but the program takes 55 seconds to load data for a 3-minute video. If I load five videos, then it takes approximately 4m30s, which is roughly 55 seconds multiplied by 5.
It's a huge time, imagine that for a 2hr trip I would require almost 40 minutes to load the entire GPS track.... how can it be?

On the contrary, Dashcam viewer looks much faster but it's really expensive....
No idea.

When I load my files into Dashcam Viewer the GPS location on the map is almost instant.

I'm assuming you are transferring the files to the PC first?
One thing that has just occurred to me, is this all files because quite often the first file in a journey doesn't get a GPS fix for about a minute.

Are you in a position to post a full file on Dropbox or similar with a download link so I can test it on mine?
Last edited:
What are your playback devise ? are you connecting the camera to the PC or playing from the memory card in a card reader.
Have you tried to copy files to the PC before opening them in the software of your choice.
Yes, I am viewing the files on my PC with an SSD disk.
Thanks for your willingness to test my files, Kremmen! Of course, anyone feel free to test them as well.
I have ulploaded two videos.

First Video
Second Video

Thanks a lot!
Downloading now.........

Absoloutely no problem with those files. I'm getting an instant map fix from both of them :



So it's your PC and looking at the error maybe the codecs. Did you install the one I linked to ?
Last edited:
No, I didn't, because that exe is older than mine (I have 14.6), but if 14.4 (the one you have) works, mine should work even better....
I will anyway update it, since it's clear you don't have problems and I do....
Can you please try it with DVPlayer, to see if it's loading properly?
Let me check if my codecs have been auto updated. It'll be tomorrow before I have PC access to check.
Last edited:
Mine don't auto-update, but I did it today and nothing has changed
Very odd.

There is something adrift on your PC but finding it is something else. I think my first check would be to uninstall your current codecs and install the one I linked to.

I seem to recall, ages ago, I did install a 'full' codec pack and had issues so came back to the 'basic' set I have now.
My Codec pack in Win10 'Add Remove programs' is showing as "K-Lite Codec Pack 14.4.5 Basic" and is working perfectly with Dashcam Viewer.

I'm reluctant to install another program so hopefully someone who has DVPlayer can download and check your files.

Other things to check I suppose, considering the video is playing OK is to try running without displaying the mapping section as a test.
Last edited:
After rebooting, now Dashcam Viewer plays them well (two consecutive videos, not more than that, since I have the demo version). DVPlayer still takes 50 seconds per video to load the GPS data. I have emailed their support, but haven't received any answer so far.
Thanks a lot for testing and for all the comments I have received!
The main issue was to work out whether it was the files or PC. Glad it's sorted.
I contacted the developer of DVPlayer and I complained a bit, but he tested my files and the GPS track would load in 13 seconds (which is not the best results, compared to Dashcam viewer, but still better than my 54 seconds). He offered to give me my money back, but then I tested it on my M1 iMac and the GPS tracks load almost instantly even if I load 5 videos....
So I will keep the program (much cheaper than Dashcam viewer, although with less features) and give him the money back
Bottom line, use it on your Mac and it'll work great!!
I have downloaded a python script that extracts the GPS Track from a Viofo compatible dashcam and a TS file.
On my M1 iMac, the result is the following: 4 seconds

Sat Feb 5 19:02:32 CET 2022
Selected coordinate sort method: Sort coordinates by the GPS Date.
Queueing file '20220124075637_000014.TS' for processing...
Processing file '20220124075637_000014.TS'...
File 20220124075637_000014.TS is not a MP4/MOV file.
Found a TS header.
Found 180 GPS data points.
Wiriting data to the output file '20220124075637_000014.gpx'.
Sat Feb 5 19:02:36 CET 2022

On my Windows10, instead, it took 2'36", so definitely it's a CPU issue

Thu Feb 10 09:11:36 CET 2022
Selected coordinate sort method: Sort coordinates by the GPS Date.
Queueing file '20220124075337_000013.TS' for processing...
Processing file 20220124075337_000013.TS'...
File 20220124075337_000013.TS is not a MP4/MOV file.
Found a TS header.
Found 180 GPS data points.
Wiriting data to the output file 'gpstrack.dat'.
Thu Feb 10 09:13:12 CET 2022
If VLC can play your file instantly but Dashcam Viewer or DVPlayer are struggling, it sounds like a video codec is struggling to initialise.

I would first fully remove K-Lite codec pack - codec bundles these days are largely unnecessary and can cause more problems than they solve.

Get the LAV Filters from , install those and then Dashcam Viewer (or any app which relies on Windows codec support) will use them to decode videos.

I also use MPC-HC for playing general audio and video files, it's available from here: . MPC-HC also bundles LAV Filters (does not install them, just incorporates them for when playing files directly in the player).

There's an Audio, Video and Splitter filter installed, all three are pretty decent. LAV Filter options are very customisable and support various hardware-accelerated playback, deinterlacing and codecs.