BlackVue Wi-Fi 2-Channel DR550GW-2CH

Discussion in 'DR550GW-2CH' started by marcelo, Jun 11, 2013.

  1. jermyzy

    jermyzy New Member

    Messages:
    19
    Likes Received:
    0
    Country:
    Canada
    Hey guys, my blackvue 550 has served me well for the last 2 years...however, yesterday I noticed the LED light on my rear camera was flickering on/off. Then, it was fine this morning. However, tonight, the LED has gone off and the rear camera is now dead. I unplugged the cables and replugged but rear camera is still not functioning. How to I determine if it is due to a faulty cable or if the rear camera itself has died??? Thank you!
     
  2. Ste_ac

    Ste_ac New Member

    Messages:
    2
    Likes Received:
    0
    Country:
    United Kingdom
    Hi Jermyzy,

    I have exactly the same problem as you. Worked fine for nearly two years, then one day the rear camera LED started to flicker, and sometime it doesn't work at all. This morning I wiggled the end of the cable at the front camera end and the light went off. It didn't come on again until I cut power to the camera and reconnected. Judging by what other people have said too, I am starting to think it is a problem of the very fragile connectors that are used for the AV cable. Particularly the one in the front camera.
    I think some people have had temporary "fixes" by updating firmware, but this may be due to the need to touch or move the cable rather than the firmware itself.
    As mine is out of warranty I might open up the front camera and take a closer look at the connector. I remember when the camera was new the front connector was very tight. I removed the cable a lot of times because I had the issue of the cable interfering with my DAB radio until I got a replacement, less noisy cable. I think the many times of connecting and reconnecting the cables may of loosened the connector inside the front camera.

    I'll keep you posted once I've had a look at the connector.

    Ste.
     
  3. jermyzy

    jermyzy New Member

    Messages:
    19
    Likes Received:
    0
    Country:
    Canada
    Thanks for the update Ste-ac. I believe faulty cable could definitely be the issue. When I first installed the camera, I had the cable replaced under warranty as it failed in the first month. However, since then I have not unplugged the cable at all, so not sure why the connectors would fail? Anyways, I did try unplugging and replugging the cable and it is sporadically working/not working. Let me know if you have any further updates! Thanks!
     
  4. Ste_ac

    Ste_ac New Member

    Messages:
    2
    Likes Received:
    0
    Country:
    United Kingdom
    I haven't taken the camera apart yet, but I unplugged it and rerouted the power lead the other day. When the AV cable was reattached, it is now pushed up firm against the power lead. Since then, the LED on the rear camera has been constantly on - no flickering. Everything seems to be working fine. More confirmation it must be the socket in the front camera or the end of the AV cable.
     
  5. jermyzy

    jermyzy New Member

    Messages:
    19
    Likes Received:
    0
    Country:
    Canada
    Is there a small gap between the the camera itself and connector on your front camera? (e.g. a small amount of brass showing)? I replugged the cable and there is a few mm of brass showing. I'll try to take a picture later
     
  6. TurBIce

    TurBIce Member

    Messages:
    95
    Likes Received:
    17
    Country:
    Australia
    I need another power cable for the 550,

    Can i just use any CIG cable that fits? or is the blackvue CIG cable different?
     
  7. Peter Wilson

    Peter Wilson Active Member

    Messages:
    580
    Likes Received:
    91
    Location:
    Newcastle upon Tyne
    Country:
    United Kingdom
    Dash Cam:
    Mini 0801 DashCam and Blackvue DR550GW, iPhone 4S.
    I ended up using a different one just made it easier. make sure it can handle up to 1.5Amps I think the original is 2 Amps. Or use a hard wire kit.
     
    TurBIce likes this.
  8. alexsoll

    alexsoll Well-Known Member Retailer

    Messages:
    1,627
    Likes Received:
    1,179
    Location:
    Minsk
    Country:
    Belarus
    Dash Cam:
    Street Guardian, BlackVue, TrendVision www.autodvr.by
Loading...

Share This Page