DOD LS300W Plus deleting recent files first, night time poor quality video,poor sound

muso

Member
Joined
Jun 18, 2014
Messages
58
Reaction score
11
Country
Australia
I have had this dash cam for just under 1 year. The video quality has always been pretty good but the night time quality either has deteriorated or it wasn't much good in the first place. If a car reversed into me at night and drove off hit and run I would not be able to read the number plate, all I would see is a white rectangle - which kind of defeats the purpose of having the dash cam in the first place. I find that my headlights reflect back off the number plate making it unreadable, perhaps my low beam head lights need adjusting. But most low light videos are quite blurred if there is any motion involved at all (ie me moving or other car moving, if we were both still it would be ok) The other night a car next to me ran a red light almost hitting another car. Later I tried to view the footage and the car was a complete blur, couldn't even make out what kind of car it was let a lone read the rego plate when I paused the footage. It may be a setting that needs adjusting .

Also the sound quality is not good, our voices inside the car are quite loud drowning out other noises, there is also a static sounding crackle with the audio when I go over small bumps even on smooth roads.

How do I use this 'voice recording off mode' and what does it do? Does it mute all the sound or just voices inside the car?

Lastly it seems to overwrite recent files but retains old ones. Yesterday morning was deleted but the day before and up to a week before is still there. I would have thought that files would be overwritten in date order (oldest first). Maybe it needs a software update? It does this with both my memory cards (Sandisk class 10 32 gb)

I find this dash cam a pain to program, making even simple adjustments in the menu is a real effort, when I plug it into the computer it either cycles on off on off by itself or it just gives me a blank blue screen with "Mass storage" message on it and none of the buttons respond at all. i have had to hard reset it a few times and having to figure out everything when it defaults to
Chinese language is ridiculous........hopefully a firmware update will address this and other issues.

The daytime video in full HD is good though :)

Any tips would be appreciated :)
 
Last edited:

Saar21

Active Member
Joined
Apr 11, 2013
Messages
155
Reaction score
27
Country
Israel
Hi,
The night quaility is like this in all cameras, its very difficult to see the license plates numbers because they reflect light.


"voice recording off" mute all sounds, in my camera i never had noies problem it could be caused because devices that you have in the car or somthing wrong with the camera.

You have in the camera option called G SENSOR, The sensor is supposed to identify shocks and lock the file so that they will not delete in case of an accident.
Check in the menu what is the sensitivity level of the sensor and raise the sensitivity level or turn it off.

When your plug the camera into the cumputer she will always go to mass storge mode so you be able to watch you files.
If you want to go to the menu so plug her into power source or just turn her on.
If the camera is always turn on and off its probably because the cable you are using is not good, try to use another one.
 
Last edited:
OP
M

muso

Member
Joined
Jun 18, 2014
Messages
58
Reaction score
11
Country
Australia
Thanks for all your help Saar21 :) It has been very informative. Do you know if there is a way I can remove the "AAADODLS300W" from the screen but still retain the time and date?
 
Top