Dome 201 - Mount problem!?

ext

New Member
Joined
Apr 7, 2015
Messages
7
Reaction score
2
Country
Turkmenistan
Is mount really poor that it can't fixate? Mine is dangling and slipping out even on small vibration or bumps.
What should i do to fixate on suction mount or am i connecting it wrongly?
 

Attachments

  • IMG_20160606_094930-2.jpg
    IMG_20160606_094930-2.jpg
    44.2 KB · Views: 73
  • IMG_20160606_0950182.jpg
    IMG_20160606_0950182.jpg
    28.1 KB · Views: 71

JnC

New Member
Joined
Apr 4, 2016
Messages
19
Reaction score
4
Country
United States
Inspect the opening on the camera carefully, its probably cracked. I have the same issue with mine.
 
OP
E

ext

New Member
Joined
Apr 7, 2015
Messages
7
Reaction score
2
Country
Turkmenistan
There is no crack.
 

Jean Claude

New Member
Joined
Jun 14, 2016
Messages
4
Reaction score
2
Country
Australia
I just bought one myself have the same problem. the opening is either to big or the part that goes into it is to small.
I contacted to seller and they said they will send another one out to me, lets hope its better then what i have now
 

Jeremy Wong

Well-Known Member
Joined
Apr 14, 2015
Messages
528
Reaction score
409
Location
Kuala Lumpur
Country
Malaysia
Dash Cam
Viofo A119, Viofo A119S, Xiaomi Mijia, 360 J511C, etc
Mine is mounted this way and don't have any issues...

13087177_10153819561466645_1674271092376169651_o.jpg

The mount on the DAB201 has a slight wedge shape on the suction part of the mount. It's meant to cause a tight friction fit. If you insert it backward and force it in, it could possibly cause the cracking issue. Unfortunately the manual doesn't mention this.
 
Last edited:

da wei

Member
Joined
Aug 4, 2015
Messages
87
Reaction score
18
Country
United States
where can I buy a replacement mount? I really do not like this one.
 

sammy

New Member
Joined
Oct 14, 2016
Messages
14
Reaction score
2
Country
Malaysia
Dash Cam
Dome D201, Blaupunkt BP3.0
Mine is mounted this way and don't have any issues...

View attachment 23822

The mount on the DAB201 has a slight wedge shape on the suction part of the mount. It's meant to cause a tight friction fit. If you insert it backward and force it in, it could possibly cause the cracking issue. Unfortunately the manual doesn't mention this.

Jeremy Wong can you elaborate on the "slight wedge shape on the suction part of the mount"? I can see vibration in the video image and sometime wobble image and I believe is the mount the cause the vibration (probably unable to hold the unit firmly)
 

CaptureYourAction

Well-Known Member
Retailer
Joined
Feb 6, 2016
Messages
3,471
Reaction score
1,875
Location
New England
Country
United States
Dash Cam
DOD, Dome Technologies, VicoVation, Viofo, GitUp

CaptureYourAction

Well-Known Member
Retailer
Joined
Feb 6, 2016
Messages
3,471
Reaction score
1,875
Location
New England
Country
United States
Dash Cam
DOD, Dome Technologies, VicoVation, Viofo, GitUp
CaptureYourAction, you sure are resourceful :) Thanks for the link anyway does that mean the ramp is not suppose to go in first?
You want the small end of the wedge to go in first. This will mean the mount should get tighter as you press it in. It should not be loose when fully pressed in.
 
Top