Firmware update failed

MariusM

New Member
Joined
Sep 8, 2018
Messages
1
Reaction score
0
Country
South Africa
Please advise.
I bought a Garmin 55, installed VIRB software on my Samsung Galaxy S8 phone and after connecting to the dash cam VIRB indicated that there was a new software version available for the dash cam (currently on 3.70, 3.80 now available). Software was downloaded and copied over to the dash cam. VIRB indicated that the device should be restarted to begin update. Device restarted and is now stuck on what seems to be the upgrade progress screen. Blue triangle with progress bar. No response.
Is there any way to Reset/Restore the dash cam?
 

SawMaster

Well-Known Member
Joined
Apr 10, 2015
Messages
5,357
Reaction score
4,798
Location
SC
Country
United States
Dash Cam
G1W-S, G1W-HC, G1W clone, B1W, N2 Pro, K2S, B2W, (ex Mobius)
Perhaps this would be better in the Garmin forum, as there are some people there who really know that camera well. Maybe @DashCamMan can move it there for you.

Phil
 

BlueTriangle

New Member
Joined
Nov 13, 2018
Messages
2
Reaction score
1
Country
United Kingdom
Please advise.
I bought a Garmin 55, installed VIRB software on my Samsung Galaxy S8 phone and after connecting to the dash cam VIRB indicated that there was a new software version available for the dash cam (currently on 3.70, 3.80 now available). Software was downloaded and copied over to the dash cam. VIRB indicated that the device should be restarted to begin update. Device restarted and is now stuck on what seems to be the upgrade progress screen. Blue triangle with progress bar. No response.
Is there any way to Reset/Restore the dash cam?
Did you find a resolution? I have updated from an earlier version to 3.90 and the update also seems stuck (or taking an exceedingly long time).
 

lacibaci

Well-Known Member
Joined
Mar 5, 2015
Messages
1,247
Reaction score
531
Country
United States
Did you try factory reset and a new (or different) card?
 

Bradford D

New Member
Joined
Oct 17, 2018
Messages
8
Reaction score
3
Country
United States
I had a similar problem on the 3.9 update..... the DS55 was hooked up to my computer and seemed stuck after the download - so I finally just unplugged it, thinking that it would either a) dump the download so I could start over or, b) remain frozen..... as it turned out, after a minute I plugged it back into a power source and it performed the update at that time.

Good luck!
 

BlueTriangle

New Member
Joined
Nov 13, 2018
Messages
2
Reaction score
1
Country
United Kingdom
I had a similar problem on the 3.9 update..... the DS55 was hooked up to my computer and seemed stuck after the download - so I finally just unplugged it, thinking that it would either a) dump the download so I could start over or, b) remain frozen..... as it turned out, after a minute I plugged it back into a power source and it performed the update at that time.

Good luck!
That was my experience, I then booted into the device fine and viewed my folders in file manager. The next time I went out in the car as soon as I plugged it in it stated it was updating, rebooted and then proceeded to freeze. In the end I kept it on charge to see if the update would complete, and four hours later the progress bar hadn't moved so I held the power button in until it turned off. Turning the device back on it was fine, I was prompted with a message saying the update was successful (so I'd suggest there is an issue with the installer). I've now tested the camera again in the car and it's working as expected.

Thank you for your assistance, hopefully the additions to this thread will help others.
 
Thread starter Similar threads Forum Replies Date
lacibaci Dash Cam 55 1
lacibaci Dash Cam 55 2
lacibaci Dash Cam 55 11
truetaurus Dash Cam 55 22
lacibaci Dash Cam 55 0

Similar threads


Top