Frozen blackvue 550GW-2CH help!

Discussion in 'DR550GW-2CH' started by Adam H., Aug 7, 2017.

  1. Adam H.

    Adam H. New Member

    Messages:
    14
    Likes Received:
    0
    Country:
    United States
    Hi, Im hoping someone can help me. I realized 2 days ago my time and date was incorrect on the dashcam, I changed it in the settings on PC and put the card back in the blackvue but it froze upon turning on. Blue gps light stays on frozen and nothing happens, no voice, no other lights. I tried 2 different SD CARDs and format both, still nothing. Even with no SD card the camera blue light goes on and stops there. Any suggestions?
     
  2. Hillbilly

    Hillbilly Well-Known Member

    Messages:
    1,548
    Likes Received:
    220
    Country:
    Australia
    Try disconnecting the rear camera and try it Coincidentally I am having similar date problems with my 500 However it came right after about a 20 min drive when GPS kicked in
     
  3. Adam H.

    Adam H. New Member

    Messages:
    14
    Likes Received:
    0
    Country:
    United States
    I have to say, I already tried disconnecting the rear and only connecting the power cable, no matter what i do, even with a formatted and empty card before firmware installation the blue gps light just goes right on and stays on forever, i went for a 30 minute drive and still nothing, it just stays like that. I'm at a complete dead end. Wondering if it just bricked itself and its completely dead in need of repairs
     
Loading...

Share This Page