My geko gear Orbit 960 dash cam won't update firmware. Need help with this.


New Member
Mar 15, 2023
Reaction score
Denver, Colorado
United States

I am a first time poster here and am not sure if this right forum for this.

I recently purchased a My Geko Gear Orbit 960 dash cam and can't the camera to update its firmware. The camera came with version 1.06 and I downloaded the newest firmware from Sep. 2021 (version 1.08) and downloaded the file to my computer. The instructions on the My Geko Gear website say to insert the microSD card into a SD card adapter and plug it into a card reader, then to unzip the firmware file and transfer the folder to the microSD card. Afterwards, the instructions say to re-insert the card into the dash cam and it should re-boot after updating (the process should take 1-2 min).

I am using a Kingston 128 GB microSD card for the dash cam and have tried everything, from transferring the whole version 1.08 folder to the root page of the microSD (the one with the CARDV folder), then trying to transfer the entire folder into the CARDV folder, and trying to put the version 1.08 folder in to the video sub-folder.

Afterwards, I tried transferring the contents of the version of 1.08 folder to the root page of microSD (the one with the CARDV folder), then trying to transfer the contents inside the CARDV folder, and so on. Nothing has worked and the camera is stuck on version 1.06.

Additionally, the camera displays km/h instead of mph on the video stamp despite me programming the location.

Does anyone have this camera or other My Geko Gear camera and are you familiar with how to update the firmware. So far, I like the camera as the image quality is excellent, but not being able to update the firmware is really frustrating.

Thank you.
Welcome to the forum Broncosfan888.

Are you sure you update correctly, in general firmware updates are done with a file named ( something ) .bin

So some times you have to unzip a file to get the .bin firmware file ready to go, also if you have been " panicking " and download the same or more files, they might be named the same but then as there are more have been added the suffix (1) ASO
If the firmware have that and then are named something(1).bin, the firmware will not load as its not the correct name.

Also i have tried a few times where i could not load a firmware from the larger cards i have used 128 / 256 GB sized memory cards, so i have instead used old 8 - 16 and 32 GB cards for that job

In general you just put the .bin firmware in the root of the card, put it in the camera and it should then load, often with one LED flashing rapidly while that happen.

I am not at all familiar with this brand of cameras, so i can only offer you generic stuff. It is not a brand that see much mentioning in here as you probably have seen looking around in here
Hello kamkar,

Thank you for the welcome and for helping with this.

I do remember seeing a couple of .bin files in the folder and will try to just install those. They had the format of “something.bin,” “somethingzip.bin,” and “updater.bin.” I will try to post a screenshot of what I am seeing.

I will also try a smaller microSD card to see if that will work.

I believe My Geko Gear, used to be owned by Papago and was sold to Adesso last year.
I reached out to My Geko Gear/Adesso support regarding the firmware issue I was having thankfully they were able to help me get the camera updated.

Apparently, you have to open the firmware folder on your computer and transfer the 10 or so files to the root folder of your microSD card. Afterwards, you have to make you sure the camera is off when reinserting the microSD card.

Then you press the left middle button on the back of the camera (this the button you usually press to access the camera’s settings) while simultaneously pushing down on the camera’s power button located on the top of the camera on the right side. You should see the red led flash and the screen will remain off for about 2-3 minutes. Afterwards, the camera will turn on automatically and the update is complete.

With the version 1.08 update under the settings, there is now an option for speed to be measured in mph or km/h.

Thank you to everyone who helped with this issue and I hope this can be helpful if anyone else runs into this problem.