SG9663DC card replacement issue


Feb 23, 2013
Reaction score
United States
My Street Guardian SG9663DC has worked perfectly since May 2020 when it was installed using the hardware kit. Last the screen stopped updating and I found the Sandisk Ultra 128GB card had become read-only. I ordered the same card, inserted it into the Street Guardian, and formatted the card. That quickly finished and now the dashcam now seems messed up and at this point I'm not sure what to try next.

The dashcam is now doing this:
  • It's emitting two fast beeps every few seconds and I can't figure out how to stop it
  • There's no PIP showing the rear camera at the bottom right part of the display even though the display says PIP is ON.
  • The screen in the top right alternates showing '08:34:37' and '17:09:15'. Just below that is alternates showing '1080P30' and '1080P30, 1080P30'
  • The REC button is flashing very fast. I don't see the record circle at the top left of the screen
  • Pressing the menu button mostly does nothing. One once in a while I can get to the menu screen.
hmmm I would unplug the rear camera cable and gps cable.
Get a hold of a 32GB card and perform a firmware update. You can also try an alternative mini USB. Power source as a final test. It’s hard to see what’s going on very unusual. If you exhaust troubleshooting we can offer a discounted main camera drop-in plug-and-play replacement. (Since it’s out of warranty)
08:34:37' and '17:09:15'. most likely indicates 1ch vs 2ch total recording time left on the card. Because it fluctuates it most likely poor connection to the rear camera. Check rear cam video cables are tightly inserted into the corresponding ports.
As a test you may unplug rear camera and run main unit only. See if it makes any difference?
What FW version is your dashcam?
The FW is SG20171130_V1.15. I tested the card in a PC and all looked good, then I tried it in the dashcam again with the rear camera unplugged. The screen and buttons respond normally now and the beeping stopped. It's running normally now as a single camera system.

If I plug in the rear camera, it's not showing up in the menu system or PIP. The rear camera seems plugged in properly but the cable is moves whenever the hatchback is opened and while that's not often it could be too many times across the last couple years. I'll do more testing when it's a bit warmer outside and see if I can get it to work. For now, I have a functional front camera system so that's good for the day.

Thank you sincerely for very fast help!
That is a good sign if system works with unplugged rear camera. Yeah, most likely too many bending on hatchback part. However if it is properly installed (giving additional "lose" point for cable) it should serve long time.
PIP won't show on the menu if rear cam is unplugged.
You may also update to the latest v1.49 FW. Your v1.15 is too old.

See if it makes any difference. However if rear cable is "broken" it wont fix the thing.
Original kit came with shorter video cable. You may run it across the car to the rear cam "lose" just for the test purpose to see if it will fix the issue before and/or after the FW update.
Let us know.
Last edited:
I am amazed i have not yet tried a rear camera cable go bad ( for any brand camera ) i have after all tried a few since dual channel became a thing.

now i probably jinxed myself.