Battery always 0% even though its fully charged

Brambolinie

New Member
Joined
Mar 7, 2017
Messages
2
Reaction score
0
Country
Netherlands
Hi there! I recently got a Xiaomi Yi action camera with firmware version 1.4.8 . It worked awesome until it ocnstantly showed a red light when turning it on(still fully functional). In the app i only saw that my battery was 0%, i charged it with an external charger, and 2 other batteries, which i got from an accessory pack. Is it the battery that is broken or my camera, i tried bending the pins and updating firmware (now 1.5.6). BTW it is a Z25L Model. Thank you in advance!
 

Joseshka

New Member
Joined
Apr 17, 2017
Messages
4
Reaction score
0
Country
Spain
I have the same issue after I downgraded to 1.2.13. Red light 0 % battery all the time. There's no way of reverting to the original firmware 1.4.8. Can't even find it in the official website. Did you manage to fix it somehow? Mine is also Z25L BTW.
 
OP
B

Brambolinie

New Member
Joined
Mar 7, 2017
Messages
2
Reaction score
0
Country
Netherlands
I have the same issue after I downgraded to 1.2.13. Red light 0 % battery all the time. There's no way of reverting to the original firmware 1.4.8. Can't even find it in the official website. Did you manage to fix it somehow? Mine is also Z25L BTW.
I didn't yet, but i would love to know if there is a fix and if you manage to fix it, how you did it. Thanks for the reply though, i'll update this thread once i figure it out though
 

Joseshka

New Member
Joined
Apr 17, 2017
Messages
4
Reaction score
0
Country
Spain
But did you downgrade to an older firmware version?
 
Top