Fix invalid SN "language adaptation error" - pink screen

kamaov

New Member
Joined
Sep 19, 2018
Messages
8
Likes
0
Country
Czech Republic
#41
Dzienkuje za info i pomoc...
 

kokoaung

New Member
Joined
Jan 18, 2017
Messages
2
Likes
0
Country
Myanmar
#42
Untitled-1 copy.jpg
For fix this is only one way (╯︵╰,).
For people from europe: people who are interested send camera to me for repair please write to my e-mail dwro(dot)ddr(at)gmail(dot)com. Repair cost 50 PLN, shipping outside my country around 20 PLN.


This solution works with all yi dash models.
Connect to UART port on mainboard. Remember to connect GND too.

If you're using arduino as adapter then short RESET to GND for bypass uC and connect RX -> UART RX, TX -> UART TX. If USB UART adapter then connect RX -> UART TX, TX -> UART RX.

Chinese arduino with CH340T and etc. (not atmega8 programmer) probably won't work as adapter.
Connect to adapter using putty with baud rate 115200. I'm using linux and for me device is listed as /dev/ttyACM0.

If no error then adapter connected succesfully. Plug power cable and you will see booting messages.

Type "netcar sn yourserialnumber" (command with small letters, serial number with big letters) and press enter.

And voilea.


Problem solved.
Now i have this step...
How to type SN in putty
Helpme,Sir
 

shironator

New Member
Joined
May 14, 2018
Messages
1
Likes
0
Country
Slovakia
#46
I read that in putty settings, you need to set those. And then you should see what youre typing into command line.
05.jpg
 
Top