Problems with SGGCX2PRO+

Advocado

New Member
Joined
Sep 19, 2019
Messages
19
Reaction score
2
Location
Basement
Country
United States
Dash Cam
DR650GW-1CH, DR900S-1CH
Hello,

Recently I bought this dashcam from Amazon. I was super excited to see how good this camera is ... and I was disappointed, to say the least.

I faced two major issues with a dashcam:
The first problem is well described in this thread: This thread from Dashcamtalk
Except that setting set to 2-wire and I'm running off the dashcam's 12V power brick.

The second problem is the video quality. I set the camera to 1080p 30 fps because I've heard on this forum that the quality is better @30fps.

However, the compression rate is terrible. All recordings are super pixelated. None of the license plates are readable. Heck, even my own hood is super-pixelated.
Here are some snapshots:
Pic2.PNG Pic1.PNG

Link to video #1

Link to video #2

I tried two different SD cards: One which camera came in (SanDisk HE) and the second one is Samsung 64Gb Evo Plus. No luck, same awful quality.

My main question, is it normal? Am I having too high expectations or is there something wrong?

Setup:
- All protective films removed.
- CPL not attached
- Standard power supply
- 1080p30
- 3 min recording
- Stock 1.22 FW

Hope I will be able to learn something... Thanks!
 

jackrussell

New Member
Joined
Sep 13, 2019
Messages
4
Reaction score
3
Location
nova scotia
Country
Canada
Hi Advocado . I just installed my new SG x2Pro+ yesterday and noticed a setting in the menu for the quality on firmware ver 1.22 . Just a suggestion to see what setting yours is set to? Go to : Menu, setting for quality the options are: Standard, Medium, High
 
OP
Advocado

Advocado

New Member
Joined
Sep 19, 2019
Messages
19
Reaction score
2
Location
Basement
Country
United States
Dash Cam
DR650GW-1CH, DR900S-1CH
Hi Advocado . I just installed my new SG x2Pro+ yesterday and noticed a setting in the menu for the quality on firmware ver 1.22 . Just a suggestion to see what setting yours is set to? Go to : Menu, setting for quality the options are: Standard, Medium, High
It's set to High
 
OP
Advocado

Advocado

New Member
Joined
Sep 19, 2019
Messages
19
Reaction score
2
Location
Basement
Country
United States
Dash Cam
DR650GW-1CH, DR900S-1CH
Hi just a quick reply for now as I’m jumping into a 2 hour meeting. Please update to this even newer firmware that has higher bitrate especially in 60fps single channel mode. I’ll follow up more later today

I will do that today. Thank you.
Please, can you tell more about this update? I want to get the best quality possible, do I need to go with 30 or 60fps?
What about reliability? Will it have issues, like during the hot summer?

Thanks!
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
48,415
Reaction score
26,736
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
I will do that today. Thank you.
Please, can you tell more about this update? I want to get the best quality possible, do I need to go with 30 or 60fps?
What about reliability? Will it have issues, like during the hot summer?

Thanks!
try 30 and 60 and see which you prefer, in previous version the 60fps bitrate was fixed, it's adjustable in this version
 
OP
Advocado

Advocado

New Member
Joined
Sep 19, 2019
Messages
19
Reaction score
2
Location
Basement
Country
United States
Dash Cam
DR650GW-1CH, DR900S-1CH
try 30 and 60 and see which you prefer, in previous version the 60fps bitrate was fixed, it's adjustable in this version
sg22.PNG
sg12.PNGsg11.PNG

I don't know guys. Something doesn't work out...
I flashed V1.23, wiped SD card, restored default settings, set up to Highest quality and same choppiness in the picture. Can someone prove or disprove quality? Is this how it is supposed to be??? I can't see any license plate in ANY distance. Day or night.
 
OP
Advocado

Advocado

New Member
Joined
Sep 19, 2019
Messages
19
Reaction score
2
Location
Basement
Country
United States
Dash Cam
DR650GW-1CH, DR900S-1CH
need unedited video, any samples you want to send is fine
Ok, Sending two videos. Please mute my trash audio, or your ears and sanity will go down :D
 
OP
Advocado

Advocado

New Member
Joined
Sep 19, 2019
Messages
19
Reaction score
2
Location
Basement
Country
United States
Dash Cam
DR650GW-1CH, DR900S-1CH
Another thing I noticed. while I'm standing - picture quality is very good. As soon as I start to move, the picture falls apart.
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
48,415
Reaction score
26,736
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
Another thing I noticed. while I'm standing - picture quality is very good. As soon as I start to move, the picture falls apart.
this issue I see has more to do with the conditions, the silver and white cars are reflecting the sun, you may find the low cut AE setting works better for you, you can adjust the EV level to improve those sorts of situations but you may find that has a negative impact at other times, a bit of trial and error involved to work out what works best for your situation, some examples of the effects of changing EV shown here https://dashcamtalk.com/forum/threads/understanding-of-wdr-on-off-vs-ev-exposure-value-settings.13732/

another firmware coming soon with some further image related adjustments, later this week maybe
 

jackrussell

New Member
Joined
Sep 13, 2019
Messages
4
Reaction score
3
Location
nova scotia
Country
Canada
Hi Avocado, Here are my settings, I don't know if they will make any difference for your setup but may be worth a shot to see if it helps any: firmware v 1.23 , frequency 60Hz , AE centered weighted metering, EV +0.0 , quality high, Resloution 1920 x 1080 60fps and I'm using a cpl filter as well with just the front cam X2Pro+ with the hardwire kit.
 
OP
Advocado

Advocado

New Member
Joined
Sep 19, 2019
Messages
19
Reaction score
2
Location
Basement
Country
United States
Dash Cam
DR650GW-1CH, DR900S-1CH
this issue I see has more to do with the conditions, the silver and white cars are reflecting the sun, you may find the low cut AE setting works better for you, you can adjust the EV level to improve those sorts of situations but you may find that has a negative impact at other times, a bit of trial and error involved to work out what works best for your situation, some examples of the effects of changing EV shown here https://dashcamtalk.com/forum/threads/understanding-of-wdr-on-off-vs-ev-exposure-value-settings.13732/

another firmware coming soon with some further image related adjustments, later this week maybe
Ok, I will try.
However, this will help in plate readability.
What about the blockiness of the overall picture?
And camera not booting up from time to time, lol.
 
OP
Advocado

Advocado

New Member
Joined
Sep 19, 2019
Messages
19
Reaction score
2
Location
Basement
Country
United States
Dash Cam
DR650GW-1CH, DR900S-1CH
Hi Avocado, Here are my settings, I don't know if they will make any difference for your setup but may be worth a shot to see if it helps any: firmware v 1.23 , frequency 60Hz , AE centered weighted metering, EV +0.0 , quality high, Resloution 1920 x 1080 60fps and I'm using a cpl filter as well with just the front cam X2Pro+ with the hardwire kit.
So, pretty much standard settings.
Can you upload your video to some hosting, like dropbox? So I can download and compare with mine.
Thanks
 
Top