Review: Firefly 6S 4K Wi-Fi Sports Action Camera with Gyro, NT96660 & Sony IMX078 (Gearbest.com)

GearBest

Well-Known Member
Retailer
Joined
Jul 7, 2014
Messages
1,069
Reaction score
168
Location
Shenzhen
Country
China
To Developers
Please add ISO 3200 and 6400 in new firmware and bitrate 40mbit/s in all resolutions
Thank you!
It is a good idea! Thanks for your suggestion.

We will mention this idea to manufacturer!;)
 

shodan

New Member
Joined
Jan 8, 2016
Messages
9
Reaction score
1
Country
Canada
Hello,

I purchased a Firefly 6S last month from gearbest. The video quality is ok but the WIFI barely works.

I installed the Final Cam app (I'm on android, Moto X 2nd gen phone). When it works, it is great. However the problem is that it almost never works.

I try to add the camera and even though it sees the Firefly camera, it almost always says Add camera fail.

Once it does manage to add the camera, I try to connect to it, it says Network Connect Fail.

I live in rural Canada, I disconnected my wifi router, there is not a single wifi transmitter for 0.5KM around here. No 2.4ghz intereference anywhere.

Still it says Network Connect Fail 49 out of 50 try. It usually takes more than 20 minutes of retry retry retry until finally it connects. I only use the final cam as a viewfinder.

This makes the camera very hard to use.

I think I will return it and get a camera with a LCD.

It would have been a very good camera otherwise.
 

Splinter

New Member
Joined
Nov 27, 2015
Messages
23
Reaction score
4
Country
Australia
Hello,

I purchased a Firefly 6S last month from gearbest. The video quality is ok but the WIFI barely works.

I installed the Final Cam app (I'm on android, Moto X 2nd gen phone). When it works, it is great. However the problem is that it almost never works.

I try to add the camera and even though it sees the Firefly camera, it almost always says Add camera fail.

Once it does manage to add the camera, I try to connect to it, it says Network Connect Fail.

I live in rural Canada, I disconnected my wifi router, there is not a single wifi transmitter for 0.5KM around here. No 2.4ghz intereference anywhere.

Still it says Network Connect Fail 49 out of 50 try. It usually takes more than 20 minutes of retry retry retry until finally it connects. I only use the final cam as a viewfinder.

This makes the camera very hard to use.

I think I will return it and get a camera with a LCD.

It would have been a very good camera otherwise.
Yeah the WiFi doesn't work properly even when connected. I bet either firmware issue or cheap WiFi chip. I just connect a card reader to my android phone to review video on the go... Very disappointing WiFi feature.

**Edit** yep don't bother using WiFi as the viewfinder. Better swapping to a camera with an LCD as you say.
 
OP
Sunny

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,036
Reaction score
1,691
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
Hello,

I purchased a Firefly 6S last month from gearbest. The video quality is ok but the WIFI barely works.

I installed the Final Cam app (I'm on android, Moto X 2nd gen phone). When it works, it is great. However the problem is that it almost never works.

I try to add the camera and even though it sees the Firefly camera, it almost always says Add camera fail.

Once it does manage to add the camera, I try to connect to it, it says Network Connect Fail.

I live in rural Canada, I disconnected my wifi router, there is not a single wifi transmitter for 0.5KM around here. No 2.4ghz intereference anywhere.

Still it says Network Connect Fail 49 out of 50 try. It usually takes more than 20 minutes of retry retry retry until finally it connects. I only use the final cam as a viewfinder.

This makes the camera very hard to use.

I think I will return it and get a camera with a LCD.

It would have been a very good camera otherwise.
Have you tried firefly app?
Mine connects most of the time easily.
 
OP
Sunny

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,036
Reaction score
1,691
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
What is the app name ? It's it in the play store?
Name is none other than Firefly itself. ;)
I don't remember but I think I had to download from the product site. The one from Google play didn't work, or was it for 5S?...

 

shodan

New Member
Joined
Jan 8, 2016
Messages
9
Reaction score
1
Country
Canada
Installed the firefly app from the play store.

Didn't work, just say "is connected to the camera" and then nothing happens.

Installing apps from some website called 91.com sounds really sketch ...

Guess I don't have a choice ......
 

shodan

New Member
Joined
Jan 8, 2016
Messages
9
Reaction score
1
Country
Canada
I have tried the app from the QR code. It installed another app called Firefly which looks identical.

I connected the phone's wifi to the camera and started the app.

It says "Is connected to the camera Please keep the camera steady" and then I wait forever and nothing happens.

This camera's wifi viewfinder is unusable.
 
OP
Sunny

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,036
Reaction score
1,691
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
I have tried the app from the QR code. It installed another app called Firefly which looks identical.

I connected the phone's wifi to the camera and started the app.

It says "Is connected to the camera Please keep the camera steady" and then I wait forever and nothing happens.

This camera's wifi viewfinder is unusable.
I think it's the user error. ;)
I just tested it and worked within a second.

FIRST, IT DOES NOT WORK IN 4K MODE.
So switch it to 2.7k or lower resolution.

SECOND, CONNECT TO FIREFLYXXXX WIFI ON YOUR PHONE BEFORE OPENING THE APP.
If you just open app but phone is connected to your home router, it does not work.

That "Is connected to the camera" is a typo and wrong, it meant "It's connecting to the camera". Chinese to English conversion messed up.
When it's connected, you don't see any message but live view.
 

Gibson99

Well-Known Member
Joined
Jun 20, 2014
Messages
9,065
Reaction score
7,578
Location
Houston, we've had a problem, Texas
Country
United States
Dash Cam
(2x) A119, (2x) A118c, iTrue X3, Git1, Git2
before blaming it on the user...

i know that running custom roms seems to break the wifi apps for these cameras. i have a galaxy s3 running cyanogenmod (have actually tried cm12, cm13 and pac-rom with the same results). with this phone, i CAN connect to the wifi of both git1, git2 and a discovery DS200 action cam (all novatek cameras). however, the apps for each camera will NOT connect to the camera. I tried the official DS CAM app for the DS200, and tried finalcam and FN cam with both gitup cameras - no dice.

that said - my galaxy tab2 7" tablet running the stock rom (android 4.3 i think) works PERFECT with all 3 cameras.

i know the motoX runs a pretty bare bones version of android similar to cyanogenmod, so maybe that's the problem? are you running xposed frameworks or something like privacy guard, app killers or even a wakelock detector that could somehow be interfering? i haven't done much troubleshooting on my phone since i have a tablet i can use instead, but i'm just throwing this out there since i know i'm not the only one who will have this problem. i had the same problem on my previous phone, also running CM.
 

shodan

New Member
Joined
Jan 8, 2016
Messages
9
Reaction score
1
Country
Canada
I was running the tests at 1080p30 and I was connected to the firefly wifi before starting the app (my own router disconnected from the wall)

I'm running a bone stock Moto X 2nd

I made a video of the Firefly 6S Wifi not working.


Good design prevents user error from being a possibility but given the typo on the first line of text you encounter in the app, I'm going to take a guess and say design not so great.
 
OP
Sunny

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,036
Reaction score
1,691
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
I was running the tests at 1080p30 and I was connected to the firefly wifi before starting the app (my own router disconnected from the wall)

I'm running a bone stock Moto X 2nd

I made a video of the Firefly 6S Wifi not working.


Good design prevents user error from being a possibility but given the typo on the first line of text you encounter in the app, I'm going to take a guess and say design not so great.
Are you using the one from google or from the link on product box?
I think the one on google didn't work for me when I tried first time.
I mentioned that in the first post in this thread.

I have a brand new Moto E.
I'll try it tonight and see if it's the phone.
 

shodan

New Member
Joined
Jan 8, 2016
Messages
9
Reaction score
1
Country
Canada
As you can see in the video, I have both installed and I tried both.
 
OP
Sunny

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,036
Reaction score
1,691
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
As you can see in the video, I have both installed and I tried both.
Uninstall both and try this one: Firefly
This is from the QR code in the product manual.
Click on the gray button on the left bottom:

Firefly-6S-Wi-Fi-App-link.jpg
 
OP
Sunny

Sunny

Well-Known Member
Joined
May 31, 2014
Messages
5,036
Reaction score
1,691
Location
Denver
Country
United States
Dash Cam
More than I can review. ;)
@shodan
Just tried on the Moto E and works fine, the first time.
YOU HAVE TO USE THE APP FROM MY LINK ABOVE.
The one from google store doesn't work.

Here's my installation from download to 1st install, start to finish and wi-fi connected on the 1st try...

 

shodan

New Member
Joined
Jan 8, 2016
Messages
9
Reaction score
1
Country
Canada
Ok, I will try this third version of the firefly app later today
 

Splinter

New Member
Joined
Nov 27, 2015
Messages
23
Reaction score
4
Country
Australia
Don't believe the specs for the "30m waterproof case" I took it snorkeling today barely 10cm deep for 3 minutes and water leaked in from the lens window and filled up 1/4th the case with water. Luckily cam still works but holiday is ruined. Useless...
 

ajt1991

New Member
Joined
Jan 23, 2016
Messages
2
Reaction score
0
Country
United Kingdom
Has anyone been experiencing sound problems with recorded video on modes other than 1080p60?

I'll try and get a video on here to demonstrate, but there's a lot of distortion to the recorded audio. No problems at all on 1080p60. I'm on 2.3 firmware.
 

Similar threads


Top