DR650S [1.0.8] - Check SD card! (Well, it's there alright...)

jeez123

Active Member
Joined
Aug 4, 2017
Messages
189
Reaction score
38
Country
Denmark
Dash Cam
Blackvue DR650S-2CH
Bought my DR650S-2CH as of july 2017, it has been running approx. 24 hrs for the most time being between july 2017 and 2018. From there, it would have been in use about 15-18 hrs a day. Letting it shut off at night.
It has been running the same SD-card for this whole period - my trusted Samsung EVO+ U3 128GB that has been tested fully OK and no bad sectors found. Formatted weekly to refresh it and it's been doing it's job great..

1.0.8 to 1.0.12 and back..
It has been running firmware v1.0.8 for all this time, and then the firmware 1.0.12 released i upgraded to latest firmware in 2018 - i believe.
But, due to v1.0.12 did a fault on my rear cam, turning the recordings into green slush, i contacted blackvue on that, to get a solution, they told me that it had to be the cable going to the rear cam that was doing this, as signals from 4G, DAB and so on (wifi included) was messing with this coax cable.
They even told me to buy ferrit cores and mount on the coax to eleminate the green-errors that made the recordings of the rear cam useless - and i had to wrap the entire rear coax cable in tinfoil to prevent signal-loss.
That would include pulling out 10 meters of coax throughout the car and wrapping it in foil, reinstalling trim and all.. NOT GOING TO HAPPEN!

I knew something was up, so i reverted back to 1.0.8 and the green errors went away. Hooray! So, a firmware issue... Well, keep running on what's working then! I told blackvue and they sent me the 1.0.11 to test out. Never got so far..

Fast forward one year...

Then this thing happended 3 weeks ago, one morning.. I got out to my car, turned on the dashcam as i always do, before starting my driving, the camera turned on as usual, but insted of the usual "Blackvue for your safe driving", it told me:

"INITIALISING SD CARD"... and a bit later "Starting normal recording"..
Well... That i noticed quite fast. Not the usual welcome message. Could it suddenly have died the internal CMOS??? Did the SDcard die over night? What happend?

I did a format of the sd card via the camera, not expecting anything out the ordinary and time passed without any more "hickups". It recorded happily for about a week straight.
2 weeks on, the camera started telling me to "Check SD card" randomly.. Sometimes hours after the cams got powered on at 5.30am, sometimes it would happen only minutes after i turned it on or rebooted it via Android app.
So, i took out the sdcard (Samsung EVO+ 128GB) and did a full format on the PC via Blackvue for Windows, and reinserted the card. At that time everything seemed AOK... just until few days later, then the messages reaappered. And as last time, randomly occuring..

I went to my sd-card pusher and got a replacement via RMA on the card, it had to be faulty after 2 years of usage.. Luckily the RMA got approved and i replaced it with a new same model (Samsung EVO+ 128GB), did a format on Blackvue for Windows and carried on. Everything was fine..

- Until today...

The cam gave me the "Check SD Card" once again.. randomly occuring. It had been powered ALL day since 5.30am, running perfectly, parked for 8 hrs with parking mode on, no errors, all recordings fine. Nothing to notice. But still, it threw this error..
So, i decided to upgrade the firmware to latest v1.0.12 FOTA and reapplied all used settings as before the upgrade.

Now, i'm going for a trip for a few houndred kilometers, and expecting that the cam once again will be fine for an extended period of time before throwing me a message as to check the sd card, that really is inserted (and seems OK).

Temperature?
Temperature shouldn't be an issue. Even though we got a far bit of heat in Denmark in the last summer, at around 30-35C, i've never experienced my car getting hotter than around 40-45C in mid day, due to my 5+30% blacked out window-tint.
I wouldn't say that a 40-45C temperature should be doing the hardware something bad?

Currently in Denmark where the climate at this time of year is about 10-15C and the cam isn't feeling above warm to the touch, at all, so wouldn't be pointing at an overheat-issue for this. But i could be wrong...?

WHAT's wrong?!
Is it the internal CMOS that's failing?
I still got my 2 months of warranty covering the camera, but i'm pretty sure the model os out-of-date now and not being sold anymore on my dealership, probably is going for an upgrade. But i'd like to keep most of cables and mounts if possible. What fits the DR650S-2ch mounts - 900S or 750S? And what about power and coax?

Any advice on the camera would be highly welcome.
Thanks for reading.
Does the 750S match with cables and mounts??
 

hill

Member
Joined
May 17, 2017
Messages
74
Reaction score
14
Country
United States
Do you regularly reformat your SD card? If no - that will cause them to die. Is your SD card a high endurance type? If not, you are lucky to have it last as long as you did. In any event, that will be your easiest way to diagnose, by simply inserting a new card.
.
 
OP
J

jeez123

Active Member
Joined
Aug 4, 2017
Messages
189
Reaction score
38
Country
Denmark
Dash Cam
Blackvue DR650S-2CH
I do reformat on regular basis. Every week (sunday) i push the format-button on the cam to get it fresh (and start on a new week).

I believe the EVO+ is a high endurance card, with a 10 year limited warranty from Samsung.. It should be, right?
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
50,475
Reaction score
28,608
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
memory cards aren't red wine, they don't get better with age, two years of 18 hours a day is a lot more than I would expect it to handle
 
OP
J

jeez123

Active Member
Joined
Aug 4, 2017
Messages
189
Reaction score
38
Country
Denmark
Dash Cam
Blackvue DR650S-2CH
But then again, i replaced it with same model and specs, brand spanking new, and a week into the new card, the cam reports the error once again. That can't be the card then...? I've got yet another one to plug into the dashcam if needed, but i'm almost certain that the card isn't the problem, straight out the box.
 
OP
J

jeez123

Active Member
Joined
Aug 4, 2017
Messages
189
Reaction score
38
Country
Denmark
Dash Cam
Blackvue DR650S-2CH
Could ofc try with the 16GB from Blackvue itself, see when it gets bugged, if it gets bugged. But the reason for NOT choosing the blackvue is the amount of time recorded. I need at least 12hrs a day for parking and driving, that can't fit on that card that came with the dashcam.
 

jokiin

Well-Known Member
Manufacturer
Joined
Jan 27, 2013
Messages
50,475
Reaction score
28,608
Location
Sydney, Australia ~ Shenzhen, China
Country
Australia
Dash Cam
Too many ¯\_(ツ)_/¯
two years of 18 hours a day is probably as much as the camera is good for also, it's a tough environment for electronics at the best of times
 

BlackboxMyCar

Well-Known Member
Retailer
Joined
May 21, 2014
Messages
848
Reaction score
419
Location
Vancouver, BC
Country
Canada
Dash Cam
Thinkware, BlackVue, IROAD, Viofo, BlackSys
MicroSD cards can last anywhere from a couple of months (sadly) to a few years (if you're lucky).

Sounds normal unless the unit is burning through microSD cards every couple of months. If that's the case, the dash cam is the issue and needs to be replaced.
 
Top