Git2 - Start/Stop button - No longer working

rich skinner

New Member
Joined
May 24, 2017
Messages
1
Reaction score
0
Country
United Kingdom
Hi, any suggestions in the UK for the best place to send this off to resolder the PCB ? mine is the same as others the 3 bits of solder have disjointed on inspection
thanks
 

Quasi

New Member
Joined
Jun 5, 2017
Messages
3
Reaction score
0
Country
Slovenia
Hi,
I have the same issue with non-working start/stop (shutter) button on my Gitup2. I ve been using the camera for less than 8 months, it was never used outside of the protective casing and never received a direct physical damage and I'm very disappointed with the product that otherwise worked great. What's even worse is that in 3 days I was supposed to film a friend's master Degree concert and that would be my backup camera.

@gitup, please respond as soon as possible - should I try opening the camera and look if there are some broken soldered joints to be fixed? If that doesn't work, will you still accept a return and replace the camera with a working one?

Thanks in advance!
 

drygdryg

Active Member
Joined
Jul 9, 2016
Messages
158
Reaction score
50
Country
Germany
it was never used outside of the protective casing
Right this can cause issues with the switches in the camera. The buttons on the waterproof housing (I suppose that's what you mean) can lead to too much pressure on the camera switches, because you don't have the right feel for the required pressure. In the worst case it is not the PCB that is broken, but the switch itself is destroyed.
 

Quasi

New Member
Joined
Jun 5, 2017
Messages
3
Reaction score
0
Country
Slovenia
Thanks for the reply drygdryg. In other words - protective case itself actually hurts the camera instead of protecting it? If that is so, it shouldn't even be on the market, but then what's the point of making an action cam that can't coexist with the protective case - without it, it is absolutely useless for anything connected to "action"? There really isn't much to complain about Git2, but this can be a major issue if it's not just me and a few other users that have that problem.

PS; How can you determine wheather the switch is destroyed. It looks and feels exactly the same as before, the shutter button still makes a clicking sound when pressed.
 

drygdryg

Active Member
Joined
Jul 9, 2016
Messages
158
Reaction score
50
Country
Germany
The only reliable method for a test would be to open the cam. When there is nothing to see, maybe you can carefully check the switch witch a continuity tester. Tricky, but not impossible.

When not necessary I never use the waterproof case. You can't use an external microphone, and every extra glass in front of the lens will influence the video quality.
When the case is used, then I use the remote to operate the cam when I don't have to go into the water. The switches are very tiny devices, they should be treated with care.
 

Quasi

New Member
Joined
Jun 5, 2017
Messages
3
Reaction score
0
Country
Slovenia
Thanks. My friend did a little soldering work on it, and now it works fine. Too bad that such a good camera has this obvious design fail.

Ps; I use the waterproof case more because of protecting the camera lens from direct exposure from dust, sharp objects and anything that could scratch the lens - this is why I rarely take it off.
 

JAMESCEL

New Member
Joined
Aug 24, 2017
Messages
1
Reaction score
0
Country
Malaysia
We will contact you regarding this issue.
To all have this issues, just PM to me to solve the problem.
Hi i have PM you my issue with GitUp2 as well whereby, still have the clicking sounds, just that the button just arent responding to any clicks on the shuttle button. Appreciate if this can be solve it soonest or provide a solution video on which part to solve /solder the parts which is considered defect?
 
OP
R

Richard Lynch

Member
Joined
Jun 5, 2016
Messages
35
Reaction score
4
Country
Ireland
C
Hi i have PM you my issue with GitUp2 as well whereby, still have the clicking sounds, just that the button just arent responding to any clicks on the shuttle button. Appreciate if this can be solve it soonest or provide a solution video on which part to solve /solder the parts which is considered defect?
Can you contact @gitup again. I found their customer service good
 

Bryan Thanh

New Member
Joined
Apr 30, 2017
Messages
9
Reaction score
0
Country
Viet Nam
same as your problem. Seem the Shutter button have problem on git2 and git2p pro
 

moita.rui

New Member
Joined
Jul 31, 2018
Messages
1
Reaction score
0
Country
Portugal
Hi,
Same problem, after using the camera for some time, the shutter button stoped working!
How did you solve this?

Many thanks!
 

geesoos

New Member
Joined
Dec 29, 2017
Messages
1
Reaction score
0
Country
Poland
Hello
My camera also has the shutter problem. I tried to resolder the connection between the main pcb and button pcb, but it helped for only a shord period. After another resoldering the camera started to fire by itself, and i couldnt stopped it, the only way was to take the battery away. Is there any more timestanding solution?
grretings
 

Similar threads


Top