Is it dead? Blue light on, no voice, no wifi

efusco

New Member
Joined
Nov 30, 2017
Messages
3
Reaction score
0
Country
United States
Have had my BV installed for about 3 years and it has worked ok (other than the corrupted SD card issues every 6 months or so). I just installed a new SD card (SanDisk High Endurance 32GB) after my old one finally fried. New card seemed to work OK for a couple of days, then after a couple weeks it occurred to me that I had not been hearing the beeps on hard corners and such that I usually did.

The Blue power light stayed on, but when I tried a reformat in the camera (holding the button down), it didn't speak "Reformating the SD card" or beep or anything. I unplugged, plugged back in, tried the button again, etc. Finally tonight I took out the SD card and reformatted it with the BV software on my PC, reinstalled and nothing. Blue light is still on. The camera gets warm (though maybe not as hot as it usually does), can't get the wifi to turn on to connect to my phone, no voice, no beeps, nothing.

Is she dead, Jim? Is there more troubleshooting I can/should try?
 

hill

Member
Joined
May 17, 2017
Messages
74
Reaction score
14
Country
United States
Hey Evan! Fancy running into you here, rather than on the Prius or Tesla sites. Anyway, have you tried replacing your microSD card? one that meets the "high endurance" standard? I'll be asleep in a few minutes, but I'll check back in the morning.
 
OP
efusco

efusco

New Member
Joined
Nov 30, 2017
Messages
3
Reaction score
0
Country
United States
Hey Evan! Fancy running into you here, rather than on the Prius or Tesla sites. Anyway, have you tried replacing your microSD card? one that meets the "high endurance" standard? I'll be asleep in a few minutes, but I'll check back in the morning.
Oh, hey Hill!

The one in there now is the High Endurance SanDisk that I just reformatted and it reformatted successfully on the PC with the BlackVue software. But I haven't tried a different one than when the camera stopped working.

FWIW. Even without an SD card in the camera at all, the camera makes no sounds, doesn't turn on WIFI, etc...but the blue light comes on steady.
 

hill

Member
Joined
May 17, 2017
Messages
74
Reaction score
14
Country
United States
From my reads over the past year - a corrupt micro SD card is the most common cause of troubles. Even a corrupt card can be reformatted. I'd go out & check 1-minute files in our model X, & many of them would be corrupt. A better card cured it. Before you presume the camera is mortally wounded, give another micro SD card a chance. Also, many here say to stay away from SanDisk. I had trouble with them myself. The 'Transcend' brand - class 10, high endurance cards cost ~ 2X as much as SanDisk, & it's likely for good reasons.
.
 
OP
efusco

efusco

New Member
Joined
Nov 30, 2017
Messages
3
Reaction score
0
Country
United States
Update: I replaced the microSD card once again with a brand new Transcend Endurance. And no change. The blue light comes right on nice and steady, there's no beep or voice from the camera, can't turn on wifi. Seems like it should be working, but something isn't right. Any last suggestions/tips? Is there a way to send it in for repairs? (I'm sure it is out of warranty)
 

thacube

New Member
Joined
Feb 25, 2018
Messages
1
Reaction score
0
Country
United States
I am having the exact same issue. GPS light turns on, but camera does not. Is there any hope?
 

Scnw

New Member
Joined
May 8, 2018
Messages
1
Reaction score
0
Country
Australia
I am having the exact same issue. GPS light turns on, but camera does not. Is there any hope?
Me too, exactly what my problem is... anything can be done?
 

cardash

New Member
Joined
May 14, 2018
Messages
1
Reaction score
0
Country
Canada
Funny... I googled and found this thread with the same problem on my blackvue dr650gw-2ch dashcam as well. Anyone have a solution on how we can fix this? I had mine for 3 years now....

EDIT: I emailed Blackvue/Pittasoft and they said the NAND is defective on the unit. I was advised to contact the distributor to see if I could RMA the unit. The distributor for me was AMD/Auto Mobility and their website is "www.automobilitydistribution.com". I was quoted $279.99 as a "out-of-warranty" replacement or they could provide me a RA # to return the unit for an estimate for repair (not sure what the cost). I am waiting on their reply if shipping and handling costs are included and whether the replacement has warranty.
 
Last edited:

Focus RS

New Member
Joined
Oct 12, 2018
Messages
1
Reaction score
0
Country
Canada
I found this thread after I Googled the same problem that I have with my Blackvue. Gps light comes on but nothing else seems to work. What is the NAND? Is it repairable or I need a new dashcam? I had mine for over 2 years now. Thanks.
 

bpsmicro

Active Member
Joined
Jul 13, 2017
Messages
212
Reaction score
101
Country
Canada
It's dead. NAND is basically a reference to the on-board memory. It's not repairable.

The better dealers/distributors will quote you a flat-rate "repair" cost, which is almost never an actual repair, but replacement with a refurb. Generally they'll come with a 90-day warranty. In some cases, they'll tell you that the camera will have to be sent to Korea for replacement, and you'll be without a camera for months. But some will have an option to pay a bit more for an immediate swap (with a refurb).
If you choose to pay for an immediate swap, it doesn't hurt to ask what options are to upgrade to a newer model.

My 650S died this summer (just outside the warranty, of course), and I got a decent offer from my dealer to upgrade to a 750S with immediate cross-ship, for a bit over half the cost of buying a new one.
 

hill

Member
Joined
May 17, 2017
Messages
74
Reaction score
14
Country
United States
YesSend it back for repair or buy a new cam.
considering how hot a car gets inside, much less how hot the camera can get, it's no surprise that delicate dlectronics get fried so quickly. Although the compactness of these units is great, maybe it won't be too long until a dash cam can include cooling mechanisms - as well as being compact.
.
 

EsQueue

Member
Joined
Apr 23, 2019
Messages
81
Reaction score
75
Location
Southern California
Country
United States
DR650GW lasted about 2 years. Had time/date issue out of the box, GPS first failed then Nand. DR650S lasted 14 months about one year in, it will restart no matter what card was used. The restarting were so frequent that it couldn't record a non-corrupt video. Rear camera then failed. It sucks that there isn't a durable option available. Plan on replacing your cam every 1-2 years. I can't wait till the Chinese models start doing buffered parking mode as I'l like to pay a lot less if these need to be replaced so often.
 

Similar threads


Top