Xiaomi Yi Custom firmware with lastest revision

Mighty777

Member
Joined
Oct 5, 2015
Messages
100
Reaction score
16
Country
Switzerland
Dash Cam
Mini 806, ThiEye TM5E, Xiaomi Yi, Xiaomi Yi 2 4K
Dear magnification,

my answer would be the same one I always provide when I am faced with questions similar to yours: get a U3 card and try it. Most of the time, the problem you mentioned is due to issue with the MicroSD used (i.e. writing speed is not sufficient). I upgraded to a fast-and-cheap U3 128Gb MicroSD card (Toshiba Experia U3) and I have no problem when using my custom-made firmware that is 50Mmbit (even more than the 35Mbit posted on the first post).
 

magnification

New Member
Joined
Dec 26, 2016
Messages
2
Reaction score
0
Country
Korea, Republic Of
Yesterday, I bought a Samsung Pro plus 32GB (class 10, UHS-3) But... Nothing changed... Except the recording time. The video is still cut, but its time is longer than before about 20sec. I format the SD card with 16kb, 32kb, 64kb, but nothing worked. I installed the XIMODE, but it is not work, too. I also downgrade the 35mpbs Firmware version (1.2.12) But this way is not work neither. I don't know how to deal with this situation...

Edit: I tested again with out wifi connection, It worked almost normally, but video is still cut. (14 min 57 sec, FHD 30fps With Ximode.) Ximode works normally, either. (Deleting THM file) if i changed the Sd card's format settings, i would get normal video!
 
Last edited:

Mighty777

Member
Joined
Oct 5, 2015
Messages
100
Reaction score
16
Country
Switzerland
Dash Cam
Mini 806, ThiEye TM5E, Xiaomi Yi, Xiaomi Yi 2 4K
Yesterday, I bought a Samsung Pro plus 32GB (class 10, UHS-3) But... Nothing changed... Except the recording time. The video is still cut, but its time is longer than before about 20sec. I format the SD card with 16kb, 32kb, 64kb, but nothing worked. I installed the XIMODE, but it is not work, too. I also downgrade the 35mpbs Firmware version (1.2.12) But this way is not work neither. I don't know how to deal with this situation...

Edit: I tested again with out wifi connection, It worked almost normally, but video is still cut. (14 min 57 sec, FHD 30fps With Ximode.) Ximode works normally, either. (Deleting THM file) if i changed the Sd card's format settings, i would get normal video!

Sorry to hear the problem is not fully solved yet. I am wondering what else can be the problem (because it is indeed strange that by just disabling the wifi connection things get better...I do not see the link here....). However, in my case I always record in 2.5K at 25fps....and in this case I can confirm have no problem. When you say the video is cut, do you mean that you get the video splitted in several small files or Yi stops recording? Because if it is only file split, I believe it is OK (there might probably a size limit in the max dimension of the file....); otherwise, I really have no clue...
 

jowkon

New Member
Joined
Aug 25, 2015
Messages
3
Reaction score
0
Country
Ireland
If I downgrade current Chinese version to 1.2.13 will I get english then??
 

Martinmkd

New Member
Joined
Jan 13, 2017
Messages
1
Reaction score
0
Country
Macedonia, The Former Yugoslav Republic Of
Hey guys, I read most of the previous pages but couldn't seem to find an answer to a question of mine:

I have trouble flashing the custom firmware to my camera. I followed the instructions I found on another page, but the camera doesn't want to enter boot mode and read the firmware.bin file. Is a SD card in FAT32 format a specific requirement, because my 64GB Samsung card can only be formatted in exFAT? Also, can the problem come from not having a fully, 100% charged battery?

Thanks, this is a great community!
 

Avenger20

New Member
Joined
Dec 25, 2016
Messages
6
Reaction score
0
Country
Belgium
Would love 1.5.6 version now that the firmware for Z25L and Z26L is out.
 

benjos

Member
Joined
Sep 28, 2014
Messages
114
Reaction score
20
Location
Los Angeles
Country
United States
Dash Cam
SJ8 Pro, Rexing V1P Max, Dome D201, Xiaomi Yi
Yesterday, I bought a Samsung Pro plus 32GB (class 10, UHS-3) But... Nothing changed... Except the recording time. The video is still cut, but its time is longer than before about 20sec. I format the SD card with 16kb, 32kb, 64kb, but nothing worked. I installed the XIMODE, but it is not work, too. I also downgrade the 35mpbs Firmware version (1.2.12) But this way is not work neither. I don't know how to deal with this situation...

Edit: I tested again with out wifi connection, It worked almost normally, but video is still cut. (14 min 57 sec, FHD 30fps With Ximode.) Ximode works normally, either. (Deleting THM file) if i changed the Sd card's format settings, i would get normal video!
Do you know if the Samsung card is bad or counterfeit? Have you tested the Samsung card?

Sent from my XT1575 using Tapatalk
 
D

Deleted member 24437

Guest
Hey guys, I read most of the previous pages but couldn't seem to find an answer to a question of mine:

I have trouble flashing the custom firmware to my camera. I followed the instructions I found on another page, but the camera doesn't want to enter boot mode and read the firmware.bin file. Is a SD card in FAT32 format a specific requirement, because my 64GB Samsung card can only be formatted in exFAT? Also, can the problem come from not having a fully, 100% charged battery?

Thanks, this is a great community!
Did you format the card in the camera before you copied/pasted the .bin file to thecard?
My understanding is that 64 GB cards come formatted in exFat and the camera works with fat32
 

vsw

New Member
Joined
Mar 16, 2016
Messages
16
Reaction score
0
Country
Australia
I'm testing 1.5.6 firmware and it is working great... Will it be a 1.5.6 version? that would be great!
 

benjos

Member
Joined
Sep 28, 2014
Messages
114
Reaction score
20
Location
Los Angeles
Country
United States
Dash Cam
SJ8 Pro, Rexing V1P Max, Dome D201, Xiaomi Yi
The camera works with 64 GB SD card formatted in exFAT
 

Xiaomiau

New Member
Joined
Aug 2, 2016
Messages
13
Reaction score
2
Country
Germany
Bugger, I just got my Z26L, can I use any of the FW???? I guess I need it to use it for the XIMODE 2.1???????????

can i use the:

2) For build : 22L - 23L
https://drive.google.com/file/d/0BxO_QexYT9EAcVdRZy05OWt4alk/view?usp=sharing
???

installed FW is 1.5.6.... It seems liek they used an different sensor as well (panasonic now??) which results in an wider view and now I can not use my CPL anymore???? I got only an round picture???? Dammit, want my old Yi back... ;(
 

Mighty777

Member
Joined
Oct 5, 2015
Messages
100
Reaction score
16
Country
Switzerland
Dash Cam
Mini 806, ThiEye TM5E, Xiaomi Yi, Xiaomi Yi 2 4K
installed FW is 1.5.6.... It seems liek they used an different sensor as well (panasonic now??) which results in an wider view and now I can not use my CPL anymore???? I got only an round picture???? Dammit, want my old Yi back... ;(

I have not experienced the problem you mention. Which version do you have? I have the 23L, and it works well. If you have that version too (and a fast U3 card), try my firmware (or download the original v1.5.6 from the Yi website).
 

Xiaomiau

New Member
Joined
Aug 2, 2016
Messages
13
Reaction score
2
Country
Germany
I have not experienced the problem you mention. Which version do you have? I have the 23L, and it works well. If you have that version too (and a fast U3 card), try my firmware (or download the original v1.5.6 from the Yi website).

Ok solved it. It´s not the sensor it was a setting, I guess that was the problem with the Superview... I got the Z26L with 1.5.6. and custom Autoexc and it works just fine... (and the old 21L with Ximode2.1)... Thx for the reply...
 

Mireczech85

New Member
Joined
May 19, 2017
Messages
7
Reaction score
5
Country
Czech Republic
Not so easy. I have already tried it and get some errors during export firmware files. Maybe it solve newer version of tool.
 

Mighty777

Member
Joined
Oct 5, 2015
Messages
100
Reaction score
16
Country
Switzerland
Dash Cam
Mini 806, ThiEye TM5E, Xiaomi Yi, Xiaomi Yi 2 4K
Not so easy. I have already tried it and get some errors during export firmware files. Maybe it solve newer version of tool.

yes, use version 1.3.3 of the Ambarella Firmware Toolbox
 

Mireczech85

New Member
Joined
May 19, 2017
Messages
7
Reaction score
5
Country
Czech Republic
I have still problem with exporting firmware files. AFT 1.3.3.
 

Attachments

  • RFS Decompiler Failed.PNG
    RFS Decompiler Failed.PNG
    654.3 KB · Views: 50
Top