Viofo A129 Duo duplicating/jumping frames on rear camera/Firmware Bug Discovered

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
226
Reaction score
174
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
Hello everyone.I've bought and installed a viofo A129 Duo camera 2 weeks ago.Everything was fine the first days with the front camera installed only,but as soon I have installed the back camera I get some frame skipping problems.The problem occur only on the back camera,every 10-15 seconds.The front camera skips too in very rare ocasions and I don't consider that a problem.I use a brand new 128GB Samsung Evo Plus U3 class10 SdCard.I have installed the modded firmware 5Wi hoping that the problem was the low bitrate of stock firmware in dual camera mode,but I have the same problem with the modded firmare too.I have made factory reset and format SdCard 3 times.I used the default settings after factory reset,and WIFI is always off,no parking mode enabled.Have somebody else experiencing this problem with Viofo A129,is this normal for this model or I have a faulty unit?
 
Last edited:
OP
gabilondo77

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
226
Reaction score
174
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
I tought the same but after writing some clips on the card from my laptop(19 videoclips total 5GB),I saw it has very good writing speed.
 

Attachments

gse

Well-Known Member
Joined
Oct 22, 2013
Messages
526
Reaction score
421
Country
Russian Federation
Dash Cam
ТDR-718/ Viofo 119S/ VicoWF1
Spaces are usually associated with problems with the card.
The card does not cope with the video stream, it not only records, but also reads and checks.
As an option, disable the motion sensor and strike in the settings, see how the card behaves.
 
OP
gabilondo77

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
226
Reaction score
174
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
Thank you for your help,the motion sensor is disabled and the settings are factory defaults.I only set date/time zone/resolution and bitrate,everything is factory default.What card do you recommend to use?
 
OP
gabilondo77

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
226
Reaction score
174
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
Last edited:
  • Like
Reactions: gse

HonestReview

Well-Known Member
Joined
Feb 9, 2019
Messages
1,011
Reaction score
308
Country
United States
Hello everyone.I've bought and installed a viofo A129 Duo camera 2 weeks ago.Everything was fine the first days with the front camera installed only,but as soon I have installed the back camera I get some frame skipping problems.The problem occur only on the back camera,every 10-15 seconds.The front camera skips too in very rare ocasions and I don't consider that a problem.I use a brand new 128GB Samsung Evo Plus U3 class10 SdCard.I have installed the modded firmware 5Wi hoping that the problem was the low bitrate of stock firmware in dual camera mode,but I have the same problem with the modded firmare too.I have made factory reset and format SdCard 3 times.I used the default settings after factory reset,and WIFI is always off,no parking mode enabled.Have somebody else experiencing this problem with Viofo A129,is this normal for this model or I have a faulty unit?
The Viofo Cameras don't like specific cards. I tried a 32GB Sandisk Ultra Plus and the camera would freeze periodically. I use a Sandisk A2 Extreme and have had zero issues. One camera uses 128GB and other 256GB.
 
OP
gabilondo77

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
226
Reaction score
174
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
Ok,so I have exactly the same problem with the new 128GB Viofo SdCard.I start to belive that the A129's chipset is struggling with 2 cameras.If I disconnect the rear one is working fine and the quality is impressive at 60fps,no frame skip at all.At least I have a good quality MLC card now..
 
Last edited:
  • Like
Reactions: gse

gse

Well-Known Member
Joined
Oct 22, 2013
Messages
526
Reaction score
421
Country
Russian Federation
Dash Cam
ТDR-718/ Viofo 119S/ VicoWF1
Sample with the new Viofo card.Front camera is skipping heavy at the middle of the video but it does that in very rare ocasions and don't bother me.The rear one do this every 10-15 seconds.
I do not see the video gaps on the front and back of the camera.


Безымянный.jpg

Безымянный12.jpg
 
Last edited:

gse

Well-Known Member
Joined
Oct 22, 2013
Messages
526
Reaction score
421
Country
Russian Federation
Dash Cam
ТDR-718/ Viofo 119S/ VicoWF1
Hi @jokiin , I'm doing this with NovaTrakt-v2.4

 

nutsey

Well-Known Member
Joined
May 12, 2015
Messages
551
Reaction score
451
Location
Turkey
Country
Russian Federation
Sample with the new Viofo card.Front camera is skipping heavy at the middle of the video but it does that in very rare ocasions and don't bother me.The rear one do this every 10-15 seconds.
I can confirm there are frame problems with your footages. The rear cam drops every 92/93 frame. The front cam skips and doubles frames randomly.
 
OP
gabilondo77

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
226
Reaction score
174
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
OP
gabilondo77

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
226
Reaction score
174
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
I can confirm there are frame problems with your footages. The rear cam drops every 92/93 frame. The front cam skips and doubles frames randomly.
You are right,if I look closer is every 3-4 seconds on the rear one..Thank you for confirmation..
 

gse

Well-Known Member
Joined
Oct 22, 2013
Messages
526
Reaction score
421
Country
Russian Federation
Dash Cam
ТDR-718/ Viofo 119S/ VicoWF1
Look on the front camera video between 1:30-1:44,is skipping heavy..
I see that there are jumps, in which program you can see the video frame drop?
 
OP
gabilondo77

gabilondo77

Active Member
Joined
Jun 29, 2019
Messages
226
Reaction score
174
Location
Torrevieja
Country
Spain
Dash Cam
Viofo A129 Duo,Viofo A129 Pro Duo 4K
I don't use a program,I see it with my eyes,is like a lag in the rear cam,is like stopping for some miliseconds every 3-4 seconds,footage is not smooth. :)
 
Last edited:

gse

Well-Known Member
Joined
Oct 22, 2013
Messages
526
Reaction score
421
Country
Russian Federation
Dash Cam
ТDR-718/ Viofo 119S/ VicoWF1
With my eyes, I also see jumps, but I don’t see where the frame is missing.
 
Top